Cannot defrag

  dangerusone 11:32 06 Jan 11
Locked

I have noticed my PC seems to take longer & longer to start up lately and I thought the fact I hadn't defragged for some months (I know!!) could have some bearing.
When I try to open System Tools/De-Frag it doesn't open properly ie. no showing what the estimated fragmented files are,everything is greyed out. When I click on defrag nothing happens and when I press Control/Alt/Del I get the message "Program not responding"
I have run AVG with nothing found.

  dangerusone 11:36 06 Jan 11

I have just read the thread below this about AVG 2011, could this be causing my troubles?

  dangerusone 12:26 06 Jan 11

I have taken AVG 2011 off and gone to MSE with no improvement so I don't think AVG 2011 was the cause.
Any ideas anyone?

  Seth Haniel 12:50 06 Jan 11

in Safe mode

some program may be stopping it -- I use a third party program as windows own never seemed to work for me

  The Kestrel 13:37 06 Jan 11

I gave up using windows defragger ages ago and noe use Auslogics freeware defragger from click here. It is fast and uses very little resources.

  ame 13:38 06 Jan 11

Try the free Auslogics disk defrag - works for me.
click here

  ame 13:38 06 Jan 11

Snap!!

  mooly 14:00 06 Jan 11

Don't know what operating system you are running but seeing defragmenter and security packages reminded me of this problem I had... it's a long thread. The cause for me was a paid for security package.
After this fiasco I did a clean install, used MSE and vowed to never ever use any 3rd party cleaners etc. Result, a totally troublefree computer.

click here

  birdface 14:13 06 Jan 11

[I have run AVG with nothing found.]

If AVG is your only security program maybe try the free version of Malwarebytes.

  dangerusone 09:35 07 Jan 11

I downloaded Auslogistics, which worked fine, from "The Kestrels" link after reading that various people used it instead of Windows, also ran the freeware Malwarebytes.
Thanks for all the replies they are much appreciated.

  maghemite 16:43 07 Jan 11

Great that you were able to solve the problem :)

But just as a FYI: a common reason why defrag doesn't start up is because services that depend upon it (Task Scheduler,Disk Defragmenter,Remote Procedure Call (RPC),DCOM Server Process Launcher,RPC Endpoint Mapper) are disabled. Ensure that these are set on automatic start for defrag to function normally.

Another possible reason is that the filesystem is corrupted, so running chkdsk /r will ususally clear that up.

Also, for defragging, there are good automatic defraggers ('install and forget' type) that will monitor for fragmentation and defrag whenever necessary without the user's intervention. Quite convenient.

This thread is now locked and can not be replied to.

Sony Xperia XZ Premium review: Hands-on with the new 4K HDR phone with Motion Eye camera and Snapdr5…

1995-2015: How technology has changed the world in 20 years

Best laptop for design and art 2017: we test Apple, Dell, HP, Lenovo and Microsoft's best models…

CarPlay tips & troubleshooting guide: CarPlay tips & troubleshooting guide: Get the most from…