Cannot connect Epson 830 to USB

  Elija 11:48 04 Jun 03

Cannot reconnect my Epson 830 Photo Printer to USB since wiping hard drive. While the serial bus controllers appear to be ok in system properties,I have tried several times load usb drivers, even downloading updates from Epson. No joy, I still have a yellow question mark on other devices/pci usb. Running fully updated Windows ME,K7N2 Athlon Board,Asus Graphics. loads ddr mem and 2x60Gb HDs. Have tried wiping hard again and doing clean re-install.

  Djohn 13:22 04 Jun 03

Have you remembered to disconnect your printer from your PC and install the drivers first.

Most, if not all USB hardware, require the installation of drivers before connection of Hardware. j.

This thread is now locked and can not be replied to.

Nintendo Switch (Nintendo NX) release date, price, specs and preview trailer: Switch price…

1995-2015: How technology has changed the world in 20 years

Best Photoshop video tutorials: 8 video tutorial websites for Photoshop

How to speed up a slow Mac: 19 great tips to make an iMac, MacBook or Mac mini run faster | Speed…