Can you help me figure out why my pc is so slow?

  Ltait1992 13:16 PM 29 Jul 13
Locked

Hey, I was hoping someone could help me to figure out why my computer has been running so slow lately. I've tried everything from uninstalling unused programmes etc, using registry cleaners like CCleaner, doing disk defrags and I've even went to the extent of doing a clean install of the OS. Heres my specs:

Intel Core i3 @ 3ghz
Gigabyte h55m-ud2h Motherboard 4gb Geil black dragon RAM 500GB HDD(Got 325GB of free memory at the moment) 850w PSU ATI Radeon HD 5770

I know that over time PC components slowly degrade with use and I was wondering if that was the case or whether it was something else. I don't know if this would make a difference but a few months ago the power supply went and I had to replace it(with the one I have listed above). I tried to switch it on one day and it powered up and switched off immediately after. Then it would automatically try to boot up again and keep repeating this cycle until I switch it off.

Help a noob out please.....Lol

  Ltait1992 13:19 PM 29 Jul 13

Intel Core i3 @ 3ghz
Gigabyte h55m-ud2h Motherboard
4gb Geil black dragon RAM
500GB HDD(Got 325GB of free memory at the moment)
850w PSU
ATI Radeon HD 5770

*Sorry for double posting but that was annoying me and I wanted to fix the layout to make it easier to read :)

  rickf 14:22 PM 29 Jul 13

The rebooting repeat could be due to overheating perhaps? If it is then you need to reapply cooling paste to cpu before slotting it back. Just a thought.

  Ltait1992 16:58 PM 29 Jul 13

Ok,I'll give that a go. It annoys me how slow it is now, I struggle playing simple games like terraria and Command and conquer Red Alert 2......Computer! Why u no work!?!? >:(

  rickf 21:43 PM 29 Jul 13

You need to clean off the old paste before applying new one evenly. While you are at it give the inside of the comp a good clean. I usually use a vacuum cleaner with the small nozzle attached. Be careful not to make contact with parts of the MoBo. DON'T FORGET to unplug the comp from the mains before doing this. Good luck

  Ltait1992 00:44 AM 30 Jul 13

Its only overheated once since Ive changed the psu that I can remember. Thinking I'm just gonna have to splash out on a new computer....I've tried everything and it's still soooooo slow. :(

  rickf 10:43 AM 30 Jul 13

The specs look OK so don't give up yet and buy a new one. Someone more experienced here might be able to shed more light on this. You have not said what graphics you have though as that might help. As you play games this becomes very relevant. Could be a graphics card prob. You might be able to upgrade the card but check what slots you have. OOPs, I see it's a Radeon card. Is it onboard? Maybe a dedicated one as an upgrade would help. Is your OS 32 or 64 bit? If 64 bit you can increase RAM say to 6g and a new graphics card? If OS is 32 bit then you are stuck with your 4g RAM as 32bit OS can't use more than about 4G RAM.

  Ltait1992 12:06 PM 30 Jul 13

I've got a ATI Radeon HD 5770 1GB and im stuck with 32bit vista. I've checked the device manager and it says it's still working. I can't really afford to buy windows 7 or 8 at the moment. :(

  wee eddie 14:20 PM 30 Jul 13

I have, I think, a fairly reasonable security set-up. WSE, CCleaner, Malwarebytes and Superantispyware. Recently my machine became reluctant to move along.

I loaded and ran Spybot S&D, then cleared it's suggested collection. Seems to have done the trick.

  Ltait1992 16:05 PM 30 Jul 13

Anyone else have any suggestions that might help?

  rdave13 09:24 AM 31 Jul 13

What security software are you running? Two antivirus programs running can cause this.

Advertisement

This thread is now locked and can not be replied to.

Sony Xperia Z5 vs Xperia Z5 Premium vs Xperia Z5 Compact: What's the difference between Sony's new ?…

1995-2015: How technology has changed the world in 20 years

Get $800 of free online Nuke and VRay rendering from Google Zync

iPhone 6S preview: What to expect from Apple's next iPhone