can share internet but not files or printer

  fluffypink 12:44 29 Jan 09
Locked

Hi, I have a pc (with printer connected) that connects directly to a modem router with wired and wireless capabilities, and a laptop that I use to connect to the internet with, either wired or wireless depending on where I am in the house. The internet works fine on both but I cannot use the files on the pc or the printer attached to it, from the laptop. I have marked the printer and files as shared. I have tried to run network setup wizard choosing "this computer connects directly to the internet. Other computers on my network connect to the internet through this computer" But when I carry on with the wizard it says "Other computers cannot connect to the internet through this computer. In addition to its internet connection, this computer must have a connection to your network" Am really confused as I thought the laptop was connecting to the internet through the PC? I have two little computer screen icon in the bottom right hand corner of the screen and if I hover over it it says "Local area connection. Speed 100.0mbps. Status Connected". This has only been there since I setup the modem router. Sorry its long but Im really confused!! Thanks for reading, any help greatly appreciated. H

  mgmcc 16:53 29 Jan 09

>>> I have tried to run network setup wizard
>>> choosing "this computer connects directly to >>> the internet. Other computers on my network >>> connect to the internet through this computer"

That is not correct. The other computers in the network are *NOT* connecting to the internet through that computer, they are all connecting to the internet via the *ROUTER*, or they should be.

If you didn't have a Router, and that computer was connecting via a USB Modem with "Internet Connection Sharing" enabled on the connection to the Modem, then the other computers would be connecting to the internet through that computer.

>>> I have two little computer screen icon in the
>>> bottom right hand corner of the screen and if
>>> I hover over it it says "Local area
>>> connection. Speed 100.0mbps. Status
>>> Connected".

In the Properties of the Local Area Connection in the Network Connections folder, there is an option to display the icon in the System Tray. What it is telling you is that your network adapter is connected to the router at 100Mbps.

Basically, to share folders you right click them and select the Sharing & Security option. Similarly, right click your printer and select the Sharing option. The most common cause of being unable to access Folders/Printers over the network is a firewall that hasn't been configured properly to allow access to the networked computers. For setting up a Network Printer in either XP or Vista, have a look at my posting click here

  fluffypink 21:32 29 Jan 09

Thanks for your reply mgmcc. I have selected "connect through residential gateway" (which I did not realise was my router!) and have now been able to run wizard on both computers. But I still cannot add network printer - on search it lists microsoft windows network under shared printers, but I cannot expand it further to select my printer. Also I still cannot file share. I have tried to look at workgroup computers but get message "workgroup name" is not accessible. you might not have permission to view this resource. the list of servers for this workgroup is not available. I am thinking this could be a firewall issue, so have turned off windows firewall and looked all through norton which all seems ok. Any ideas? Many thanks.

  oldbeefer2 14:25 30 Jan 09

There was a long thread last week on this subject click here - may help.

  fluffypink 20:27 31 Jan 09

Thanks for all who responded and helped. Turned out to be a firewall issue with Norton. All working now. Thanks again.

This thread is now locked and can not be replied to.

LG G6 review: Hands-on with LG’s bold, big-screen shot at perfection

1995-2015: How technology has changed the world in 20 years

How the 2017 Oscar-winning VFX of The Jungle Book were created

The 22 best Safari extensions | Best Safari plugins: Improve Apple's Safari web browser with these…