can connect to router and networked devices but not internet

  Caine57 07 Nov 11
Locked

All of a sudden my browser wouldn't connect to any websites. Tried f.fox, IE and Chrome. But I could connect to the router and other devices, and another computer on the same router could connect to the internet. I use OpenDNS and started getting weird messages about my IP address being used by another user. I changed back to the ISP's DNS but it did not cure. In the end I used system restore back a couple of days and now all is well. Any ideas as to what happened so I can solve it in a better way if it happens again?

  onthelimit1 08 Nov 11

There was a thread on a similar subject a few days ago here

  Caine57 08 Nov 11

Thanks, had a look but not really a solution there. I think its got something to do with the IP address but not sure. Its very definitely a device issue and not a router or a connection issue.

  john bunyan 09 Nov 11

Have you tried , in Device Manager, updating the network adapter drivers?

  mgmcc 10 Nov 11

Unless there was a genuine IP address conflict, with two items in your Local Area Network having the same IP address, the problem was most likely an issue with the DHCP Client service or a corrupt registry entry. In any case, the system restore has resolved the issue so, unless it happens again, I'd forget about it.

The only occasion in which I've experienced a router allocating the same IP address to two computers is where one PC was put into sleep mode (so the router thought its IP address was no longer in use), another computer was booted, got that same address and then the original PC was brought out of sleep mode and the conflict arose. Obviously, manually allocating the same IP address to two computers in the same network would also cause a conflict. Some other network devices - network printer, network print server, NAS drives - could have fixed IP addresses and the router's DHCP pool (the range from which it allocates addresses) should be set to avoid any fixed addresses.

  T0SH 10 Nov 11

If you are running Windows7 or Vista the single most common cause of your problem is that for some odd reason the default setting on wireless network connections is defined as a Public network ?, the consequence of this is that on some occasions windows perversely decides that while on public networks you are not permitted to connect to the internet but are allowed to connect to the LAN ? , the answer is to manually change the classification to a home network , where you will be permitted to have local and internet connectivity

Cheers HC

Advertisement

This thread is now locked and can not be replied to.

Should I upgrade to Windows 10? 8 reasons why you should upgrade to Windows 10... and 2 why you…

We are being sold the ability to spend money we don't have. And we love it

IKinema aims to banish droopy shoulders and wonky spines in animated CG characters

How to use Apple Music in the UK: Complete guide to Apple Music's features

We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message