ripendigging 16:05 PM 08 Jan 12

This is my grandsons PC.When he goes online it connects to local network but will not connect to the web,he has been having problems since Sky fitted a multiroom sky box in his bedroom.The router will not work in his bedroom so we moved the pc and router downstairs where it worked intermittantly but now will not work.His ISP is Talktalk.Thankyou for any are 4 green lights lit up on the router.

  difarn 17:17 PM 08 Jan 12

You do not say which operating system is being used. I am assuming since you moved the router and PC downstairs that you are talking about a wired connection? However, in both instances

First thing to do is to check the LAN settings.

If you are using windows 7 Click Start, and then click Control Panel. Click Network and Internet, and then click Internet Options. In the Internet Options dialog box, click the Connections tab. Click the LAN Settings button - there should be a tick in the "automatically detect settings".

Then you should look at TCP/IP settings - again in windows 7 Start-Control Panel - in search box top right type in "adapter" In Network sharing centre - choose view network connections Right click the network - should be Local Area Connection - click on Properties Go onto the networking tab and scroll down to IPv4 then click Properties Click "obtain an IP address automatically" - click ok

  ripendigging 11:52 AM 09 Jan 12

Thankyou for your reply,the operating system is XP.Professional,do the same instructions apply,I live about 20 miles away so I have to phone these instructions through.Thankyou.

  difarn 13:06 PM 09 Jan 12

These are the instructions for XP.

As there was a previous connection maybe the first thing to do is to check that drivers are up to date.

Click on Start - Settings - Control Panel
Double click on System
Click on the Hardware tab at the top of the System Properties page
Click on Device Manager

Click on "other devices" and you should find Ethernet Controller -right click - when this is expanded right on this and click - update driver.

when this is done switch off the PC and restart it.


Try:- Internet Explorer click tools internet options advanced click "reset", which resets default settings

If still no luck -

click Start, point to All Programs, and then click Internet Explorer. On the Tools menu, click Internet Options

On the Connections tab, click Never dial a connection, and then click LAN Settings.

In Automatic configuration, tick the Automatically detect settings

Open Network Connections

Click the connection you want to configure, and then, under Network Tasks, click Change settings of this connection.

If the connection is a local area connection, on the General tab, under This connection uses the following items, click Internet Protocol (TCP/IP), and then click Properties.

Go onto the networking tab and scroll down to IPv4 then click Properties Click "obtain an IP address automatically" - click ok

Good luck

  ripendigging 16:26 PM 09 Jan 12

Thank you very much for your time and trouble.

  difarn 17:38 PM 09 Jan 12

No problem - hope the situation will soon be resolved.


This thread is now locked and can not be replied to.

Best Black Friday deals 2015 live blog: When is Black Friday & what are the best tech Black Friday…

1995-2015: How technology has changed the world in 20 years

This is the animated Christmas ad everyone's tallking about

The 84 best Mac games: Brilliant RPGs, shooting games, adventure games and puzzlers for Mac OS X