Brand new floppy drive not reading disks

  CLONNEN 10:06 19 Nov 05

I have just upgraded my old floppy drive (fully functional) to a combo card reader with floppy drive unit.

So far I have only connected the floppy cables to the unit (little power plug + IDE cable).

The unit does not seem to recognize ANY of my floppy disks (used or newly formatted)

Keeps saying disks aren't formatted even though they are.

  chub_tor 10:25 19 Nov 05

Check to see if you have the floppy cable inserted the right way round, it is easy to reverse them. Usually the floppy light stays on permanently if you have got it the wrong way round.

  CLONNEN 10:46 19 Nov 05

If you mean the IDE cable it only goes into the slot one way round. Knobby bit pointing towards the bottom of the drive.

The power cable only seems to fit one way as well (red wire on the outmost side, yellow wire on the inside edge).

  muscic lover 10:52 19 Nov 05

I am in agreement with CLONNEN here, but was the Floppy / combo working before or is this its first day or so out of the box?

It MAY be faulty in which case its a trip back to the shops asking for a replacement... Check your IDE Cables first though! Secondly does it power up- faulty wiring in the power supply cable????

Other than that I am a little stumped!

  CLONNEN 10:56 19 Nov 05

Rechecked the cables - the power cable had missed one of the pins - think I've gotten all 4 pins connected now.

But I still can't get it to do anything with my floppies.

Windows ME keeps saying there is no disk in the drive or the drive door is open when I attempt to format a disk in the new drive.

  chub_tor 10:56 19 Nov 05

Yes I meant the IDE cable sorry. Can you retry your old floppy drive (I'm assuming that it was working before you upgraded). If that still works then you have ruled out a cable problem so it must be the new unit that is faulty.

  CLONNEN 11:38 19 Nov 05

Reconnected the old floppy drive - that's definitely reading disks okay.

Just an idea but do these combo units require EVERY connection to be made for the unit to function. Does having the USB header cable disconnected have anything to do with the floppy drive not working?

I wouldn't have thought so - but I can see a lot of posts on the internet about this problem with this particular model Mitsumi FA402M when I search on Google. No actual answers though.

Should I try it with the USB header connected?

  chub_tor 11:44 19 Nov 05

I can't believe that the floppy disk side and the card reader side have anything in common other than the power suppy but you might as well try it and at least see if the USB side of your new device is working. If the card reader works and the floppy doesn't you have gone one more step towards proving that the floppy drive is faulty. Then when you take it back for replacement you have a much stronger argument.

  CLONNEN 13:27 19 Nov 05

The card reader works exactly as it is supposed to (I tried my camera's SmartMedia card in it) but the floppy drive just whirrs noisily every time I try a disk in it.

Won't read, won't format - just gives me errors every time.

Looks like I'll be sending it back as faulty floppy drive.

  woodchip 13:50 19 Nov 05

Try a new cable these are more likely to fail than the drive

  chub_tor 14:17 19 Nov 05

Woodchip I think that we have eliminated the cable as it works with the old floppy drive.

This thread is now locked and can not be replied to.

Nintendo Switch (Nintendo NX) release date, price, specs and preview trailer: Codename NX console…

1995-2015: How technology has changed the world in 20 years

8 things designers (and brands) need to know about the modern woman

How to speed up a slow Mac: 19 great tips to make an iMac, MacBook or Mac mini run faster | Speed…