Bootmagic doesn't recongnize Linux partition

  tran1 18:39 21 Feb 03
Locked

Hi,

Sorry to be posting alot of questions in a short space of time.

Having successfully installed Mandrake, Boot magic doesn't recognize the new Linux partition. I went into Bootmagic menu and selected the partition that Mandrake is installed. But after reboot and selecting it in the Bootmagic boot menu, Linux doesn't load. It says something about loading the partition but just hangs with a flashing cursor.

The only way I can use Linux at the moment is to boot from Floppydisk.

can anyone help?

  zanwalk 18:42 21 Feb 03

What file system have you used? And what version of PM are you using? Earlier (pre version 8) versions of PM would only recognise Ext2 Linux partitions, and this may be your problem.

  tran1 18:48 21 Feb 03

I'm using Partition magic 8.

Here is a screenshot of my Bootmagic menu. Maybe it can be of some help. click here .

I used PM8 to create partitions for mandrake and its swapfile.

  zanwalk 18:54 21 Feb 03

Right, thanks for the link, but possibly the problem lies with Mandrake and not with PM. Did you install LILO to the Mandrake partition, if not, you will need to to enable it to boot.

  woodchip 18:54 21 Feb 03

You are better the way it's running from floppy

  zanwalk 18:58 21 Feb 03

I have W98SE and Mandrake on one computer, XP and Mandrake on the laptop, and both are successfully booted by Bootmagic.

  tran1 19:03 21 Feb 03

I did not install any of the bootloaders offered by Mandrake as I wanted to use Bootmagic.
I am happy to run from floppy but the reason I bought PM8 in the first place was for its Bootmagic.

when booting MAndrake, it goes through a series of checks and laoding/initializing tests. Is this normal?

when logging off mandrake it also goes through a series of checks to make sure eveything is halted. Is this also normal?

I ask becuase it takes quite a bit of time maybe 30-40 seconds. I would expect an OS to start in maybe 10 secs or so, like XP.

Could all this maen there is something wrong with the installation and so is cuasing Bootmagic to not recognise it?

  zanwalk 19:16 21 Feb 03

No the tests you mention are quite normal, however you will need to install LILO to the root partition of Linux, in your case that is the Mandrake partition. It seems odd but that is the way Linux works!

  woodchip 19:21 21 Feb 03

To your question yes it's normal, it's a bit like Dos starting

  tran1 19:32 21 Feb 03

Ok, I will reinstall Mandrake tomorrow. When it comes to the 'Install Bootloader' section, I should choose to install 'Lilo' instead of clicking 'Cancel', right?

Then When it reboots, Lilo bootloader will come on and I should log into windows and re-enable boot magic (so it overwrites Lilo)?

  zanwalk 19:38 21 Feb 03

Not exactly, when you get to the Install Bootloader section, it will then ask where you want to install LILO, make sure that it is to the Mandrake partition and NOT to the MBR, otherwise you will not be able to boot into Windows!

What you have in effect is two bootloaders, Bootmagic is in the MBR, and then when you choose Mandrake, LILO kicks in and gives you a 'choice' of one.

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Alex Chinneck’s giant ice cube Christmas tree at Kings Cross

Apple rumours & predictions 2017: The iPhone 8, new iPads, and everything else you should expect fr7…