booting from separate partitions, Me and XP

  donmidgey 12:53 15 Jun 03
Locked

Previously, after partitioning my hard drive and installing Me on one drive and XP on another, I was always given the option to select an os on bootup.
I have re-formatted and re-installed XP on the C: drive and have now lost the os select option.
HOw can I get it back? do i have to now re-install ME??

  powerless 12:58 15 Jun 03

Just to clarify...

Do you have two physical hard drives?

  donmidgey 23:31 15 Jun 03

no, i have 1 x 30G hard drive with 3 partitions
c: xp
d: storage
e: Me

  bab5 23:36 15 Jun 03

Win ME needs to be loaded first, then win XP installed.

Darran

  powerless 23:41 15 Jun 03

In Windows XP go to start > Run > Copy and paste:

C:\boot.ini

Now click ok.

Notepad will open and you should see this...

[boot loader]

default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS

[operating systems]

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /fastdetect

However their will be no spaces between the lines.

What you have to do is add the following line:

multi(0)disk(0)rdisk(0)partition(3)E:\WINDOWS="Windows ME"

Add this below the last line from above.

So you should have:

[boot loader]

default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS

[operating systems]

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /fastdetect

multi(0)disk(0)rdisk(0)partition(3)E:\WINDOWS="Windows ME"

Save this file. What your doing here is telling XP that there is another o/s on partition 3 which windows ME. This will also give you the option to boot into either XP or ME. By default it will boot into XP after a 30 second countdown.

IF for any reason you cannot boot into ME boot back into XP and post back.

  powerless 23:47 15 Jun 03

[boot loader]

timeout=30

default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS

[operating systems]

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /fastdetect

multi(0)disk(0)rdisk(0)partition(3)E:\WINDOWS="Windows ME"

I missed out the timeout=30

  donmidgey 22:07 23 Jun 03

hi
i followed your instructions and it did give me the choice of XP or Me on bootup, but on selecting Me it failed to start, message was
\system32\hal.dll missing.

i decided to re-install Me from the Dell manufactures disk onto my E:
this was succesfull, but on boot up i didnt get the option to select XP.

so i decided to modify the C:\boot ini
which now looks like this

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /fastdetect
multi(0)disk(0)rdisk(0)partition(3)E:\WINDOWS="Windows ME"
C:\ = "Microsoft Windows"

this didnt work so i tried the repair option given on the XP installation disk, it prompted me for a an administrator password (i have never set an administrator password) so after trying 3 times
it failed to login.
i noticed in the BIOS set up screen (f2 on boot) that the admin password was disabled, i tried to set it but it remain as disabled. (which is worrying bcos i have had this laptop from new and have never set an admin password).

after re-installing XP, i can select both Me and XP on boot up,

this now gives me 3 options on boot up

XP that works,
Me that doesnt and
Me that does
which is acceptable

but I now cannot use my broadband modem error message is
'cannot find RAS capable device'
which was the problem i had before i first re-formatted the disk.

how can i fix this without re-formatting again?

  powerless 22:18 23 Jun 03

Try updated drivers click here

(not sure about the hal.dll there is another thread wth the same problem)

  powerless 22:20 23 Jun 03

The reason you have 3 options on the boot loader screen is because you 3 entries in the boot.ini file under Operating systems.

[operating systems]

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /fastdetect

multi(0)disk(0)rdisk(0)partition(3)E:\WINDOWS="Windows ME"

C:\ = "Microsoft Windows"

I think it ismulti(0)disk(0)rdisk(0)partition(3)E:\WINDOWS="Windows ME" which is safe to remove as When you reinstalled XP it added the other C:\ = "Microsoft Windows"

  temp003 06:38 24 Jun 03

Follow Powerless's last advice and remove the line multi(0)disk(0)rdisk(0)partition(3)E:\WINDOWS="Windows ME" under the [operating systems] section in boot.ini. This will remove the non-working Windows Me option from the boot menu.

The correct path in boot.ini for selecting ME, in a dual boot with XP, is C:\="XYZ", where XYZ are any words you can choose. You can call it Windows Me, or Microsoft Windows, or anything else really.

C:\ here actually means C:\bootsect.dos, but if you just put C:\, the XP loader will by default look for the file C:\bootsect.dos. Hence the path is usually just C:
For future reference, remember that with your dual boot, all the boot files (including the one for ME) are on the C drive, the XP partition. If you reformat C drive, there will be no boot files there, and when you reinstall XP, XP Setup will not create a dual boot (because there are no existing ME boot files there for XP Setup to see).

After you've edited your present boot.ini file, back up your dual boot files. The best way to do it is to go into XP first, insert a floppy, right click drive A and select Format. On the next window that appears, just click Start, and do not select any of the available options. You must do this in XP, and must format the floppy even if it's brand new.

After formatting, copy from the C drive the files ntldr, ntdetect.com, boot.ini and bootsect.dos. The last file is the boot file for ME in a dual boot with XP.

You won't be able to boot into ME in a dual boot without bootsect.dos, even if you have the right boot.ini file.

This floppy serves as a backup of the boot files, but has the additional function as a boot floppy for the dual boot. You can restart the computer with the floppy, and you will get the same dual boot menu from which you can select which OS to go into.

Next time you need to reformat drive C and reinstall XP (and losing the dual boot), go into XP and (1) replace C:\boot.ini with the one on the floppy - you'll need to untick the Read-Only attribute of C:\boot.ini first in Properties of the file, (2) copy bootsect.dos from the floppy on to the C drive. Restart and you'll get the dual boot back.

  temp003 06:51 24 Jun 03

Try an updated driver specific to the brand and model of your modem. If it doesn't work, try uninstalling it and reinstalling it.

This thread is now locked and can not be replied to.

Surface Pro (2017) vs Surface Pro 4

20 groundbreaking 3D animation techniques

How to mine Bitcoin on Mac