Bodged reload of XP....

  Toffly 02:00 08 Mar 07
Locked

Hey all,

Right, after a series of errors recently, I decided it was time to reinstall windows XP. I'm installing on a 200GB drive, split into a 90GB (windows) parition and and a 110GB (documents) partition. I should mention that it's an upgrade disk for XP.

Halfway through formatting the 90GB drive, my power supply packed up. No idea why, but I replaced it, and all is running fine now. This of course meant, no copy of windows for setup to find and allow the upgrade. So I tried using my 2k disk, but the computer decided not to read it. So, I pulled the drive out of my 2k machine, slapped it in the XP box as master, set the XP drive as slave, booted, and installed XP on the XP drive.

However, whenever I pull the 2k drive out, and boot the XP system, I get the error

"Windows 2000 could not start because the following file is missing or corrupt.
Windows 2000 root> \systems32\ntoskrnl.exe
Please reinstall a copy of the above file.

As soon as I pop the 2k drive back in, it loads up fine, giving me the option of booting XP or 2k.


How can I sort this so that it will boot fine without the need for the 2k drive to be in the machine?

Thanks in advance!

Jase

  vinnyT 13:07 08 Mar 07

Bewfore you do anything, make a backup of all important data, if you have ghost or true image, then make an image.

I think (doing this from memory) you will have to boot with the 2k drive in, then when in xp;

-start
-run
-msconfig
-boot.ini, they'll be a bout 5-6 lines, under [Operating Systems] remove the line that refers to windows 2000
-OK

You will prob be prompted to reboot.

This should now boot without reference to 2k, the reason your pc would not boot without the 2k drive in, was that the boot.ini was looking for that drive 1st and couldn't find it.

Hope this helps.

  CLONNEN 13:23 08 Mar 07

Have you tried copying the boot files from the Win 2000 drive actually onto the XP drive (boot.ini etc need to be present on the C drive for a successful boot up).

  xania 13:24 08 Mar 07

I agree with vinnyT, but would add one or two extras. I don't think you can amend the files im msconfig. There may be a better ways, but my method is to first set up your Folder options to <View hidden files and folders> and turn off the option to <Hide protected operating system files>. You should now be able to open Boot.ini in Wordpad.


Before you amend the file, take a copy and call it boot.bak. Also, rather than delete that line, add the characters REM followed by a space.

Now you have 2 ways to redeem matters if anything goes wrong.

Save changes and reset the Folder options before rebooting. Hopefully, you problem will have been resolved, in which case you can either leave well alone or go back in and delete that line. Of course you will still have your back-up copy should abything go wrong when you delete the line. And, ince you are satisfied that all is working well, you can delete you boot.bak file.

  xania 13:24 08 Mar 07

I agree with vinnyT, but would add one or two extras. I don't think you can amend the files im msconfig. There may be a better ways, but my method is to first set up your Folder options to <View hidden files and folders> and turn off the option to <Hide protected operating system files>. You should now be able to open Boot.ini in Wordpad.


Before you amend the file, take a copy and call it boot.bak. Also, rather than delete that line, add the characters REM followed by a space.

Now you have 2 ways to redeem matters if anything goes wrong.

Save changes and reset the Folder options before rebooting. Hopefully, you problem will have been resolved, in which case you can either leave well alone or go back in and delete that line. Of course you will still have your back-up copy should abything go wrong when you delete the line. And, ince you are satisfied that all is working well, you can delete you boot.bak file.

This thread is now locked and can not be replied to.

Surface Pro (2017) vs Surface Pro 4

Where HTML5 is headed next

MacBook Pro v Surface Pro 5