bios set-up

  fuggle 13:06 04 Sep 05
Locked

Hi (first post)
I am hoping someone can give me some advice with the set-up of the BIOS (Phoenix-Award) stage in my first pc build. I will be installing Windows XP Home (includes SP2) and if I get the BIOS settings wrong can image horrible things happening.

I am using the ECS PF21 m’board with a serial ATA hard drive, and IDE CD-ROM (set to Master and installed on the second IDE channel). When the pc is working OK I hope to add another SATA drive and an IDE DVD Writer which I believe can be installed as Master on the other IDE channel.

(1) SATA and IDE settings which are causing the main problem. In the OnChip IDE Device menu, do I set the On-Chip Serial ATA to Auto (and let the BIOS sort things out) or SATA Only (for operation in legacy mode whatever that means).
In the same menu I have left all IDE settings at Auto.

(2) Is there any way to check that the BIOS settings have been made correctly. A sequence of screens appear when I switch on. How do I stop a screen to read it and how do I get to the next screen.

(3) At the moment I am not getting any beeps from the BIOS. Is this good news or bad.

  Stuartli 13:09 04 Sep 05

You can set the Bios initially to Default settings and later change them as required according to your mobo manual's advice.

  DieSse 15:43 04 Sep 05

"Is this good news or bad."

Neither - is it working, that's the important thing - if not, please outline the problem for some further help.

  Diemmess 17:36 04 Sep 05

If you are trying to stop the early screens as they whizz by you have to be very fast and jab the Pause button.

Like Stuartli said, start with the default settings and ideally the mobo handbook open. Some are better than others, but the best will explain the alternatives and defaults.

Make no changes until you are certain of the result, and preferably make one at a time so that you can go back if the change isn't a good one.

Probably not your problem but I once resurrected an old PC which couldn't beep for the simple reason there was no case speaker fitted.

  fuggle 15:38 05 Sep 05

Thanks for the advice guys (Stuartli, DieSse, Diemmess) it has altered my thinking.

If I leave the BIOS at Default settings, and change them later. When is later?

I have been assuming that the first step is to change the BIOS settings to suit the types of devices and connections. I could then access a screen which would show the settings. At this stage I have two early screens. When I Pause the first it shows

Primary Master Asus E616P3
Primary Slave not found
Secondary Master (SATA Device not found)
Secondary Slave (SATA Device not found)

It has recognised my Asus DVD-ROM and that the Primary Slave is not connected
But I cannot understand why it would be looking for SATA hard drives as Secondary Master and Slave. I understand that SATA connections are not subject to Master and Slave configurations.

It would seem that I need to make a BIOS change so that the SATA drive is recognised. There are three possibilities.

(1) SATA mode (default is IDE) or RAID. I have left this at IDE

(2) On-chip Serial ATA (default is Disabled) or the following which I have tried in turn (a) Auto (b) Combined Mode (c) Enhanced Mode (d) SATA only

(3) Onboard SATA device (default Enabled) I have left this at Enabled


The second screen shows a list of PCI listings with IRQs. Any ideas how to interpret it.

  Fruit Bat /\0/\ 15:59 05 Sep 05

Serial ATA - enabled

put DVD on secondary IDE as master.

general BIOS Settings
click here

  Stuartli 16:32 05 Sep 05

I would follow the manual's suggestions initially for Bios configuration; you can always go back and alter whatever you wish at any time.

Windows should/will assign IRQs in the appropriate sequence; you can check them out from Device Manager and then the Properties>Resource tab of whatever you are looking up.

It could be that establishing the best Services configuration (I presume you are using XP) will be of just as much importance. See:

click here

for a comprehensive rundown of what to Enable, Disable or set as Manual.

  fuggle 16:28 07 Sep 05

Thanks again guys, but no luck. I tried different BIOS SATA settings in turn, but still get the early screen indicating SATA Device not found. In the end I tried loading XP hoping that might sort it out (the forever optimist). I ended up with usual PCI Listings screen and message DISK BOOT FAILURE. INSERT SYSTEM DISK AND PRESS ENTER.

Until I can get the system to recognise the SATA hard drive it looks as if I’m stuck in square one.

  Klof Ron 16:39 07 Sep 05

You have to copy the SATA drivers from the M/B CD ROM to a floppy. Then when you install Windows you will get an option to press F6 during installation to install third party or SCSI drovers. Take this option, reboot as requested, look for an option to enter RAID function, enter and configure your RAID as 0, 1 or JBOD as required

  fuggle 18:17 09 Sep 05

Thanks Klof Ron. I'll have a good think about this one. I did not include a floppy, because I saw (some time ago) a PF21 pc working without a floppy.

After ferreting around on the net I have realised I am not alone, other guys are having exactly the same problem getting a SATA drive recognised.
.

  fuggle 08:38 30 Sep 05

Saga ends. Had to give in and call in local help. Drivers installed from m’board disc, faulty DVD-ROM ribbon cable replaced, and I’m now happily threshing around in Windows XP. Thanks for the interest guys. Now for the next crisis.

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

Prehistoric Britain is laid out in these Royal Mail stamp illustrations

Best running headphones | Best sport & fitness headphones: 4 brilliant pairs of wireless…