Big Problem With Blu-ray Burner

  DarthFuge 20:39 09 Jan 15
Locked

I have a Firstcom blu-ray burner and I've had a very annoying problem with it where it has a mind of its own. There's times when it's working fine. As soon as I want to change discs, my PC can't detect the burner and sometimes when it can it can't detect the disc inside. I have to keep on unplugging the USB leads, plugging them back in again, unplugging them, plugging them back in again and sometimes it finally works and sometimes it doesn't. When I plugged it into my other laptop it started working fine for days and then the same problem started with that laptop. I've uninstalled the burner and re-installed it and I thought that would work. No, it never. There's times when it sudden all works again out of nowhere for no reason and then it goes wrong again as soon as I change discs. At the moment I was lucky for it to detect the burner and it couldn't detect the disc inside. I've spent more time unplugging it, plugging it back in and unplugging it and plugging it back in hoping to refresh it and all I got once out of about 40 attempts was the piece of junk only detecting the burner. It's so annoying it's driving me mad. What is causing all this and how do I fix it?

Thanks.

This thread is now locked and can not be replied to.

Huawei P10 review

1995-2015: How technology has changed the world in 20 years

An overview: What leading creative agencies are doing to improve diversity

New iPad, iPhone SE & Red iPhone 7 on sale now