Belkin Wireless Problems - WLAN Light goes off

  peterbryant 23:31 PM 04 Sep 10

Hello All,

I've had a search on the Internet, but am having trouble finding the solution to our problems.

We have a Belkin ADSL Model with built-in wireless router (model: F5D7630-4A) and have used it for a good few years now, with our desktop computer.

I bought a laptop recently, and we have had problems with connectivity since.

When it is solely my laptop in use, the connection is fine, however I always need to reconnect the router several times, before the internet works permanently on my laptop.

The same occurs when other laptops are in use in the house, so it disrupts everyones connection whilst I try to connect mine.

Secondly, when we have visitors with laptops, and my laptop and theres try to connect at the same time, the internet never works, and the WLAN light switches off - not very helpful. The network appears for everyone, but when connecting, it never works.

There is probably a very straight forward solution to our problems, and if anyone could provide a solution of sorts, I'd be very grateful - I don't have much knowledge on modems!

Many thanks in advance,

  mgmcc 09:09 AM 05 Sep 10

The router does appear to be misbehaving. I'd be inclined to "hard reset" it back to factory default settings and then set it up again from scratch. There should be instructions in the manual for returning it to the factory settings, but basically it's done by holding in the reset button for a number of seconds.

  peterbryant 11:07 AM 05 Sep 10

Thanks for the post.

Have done above, but now the data light doesn't come on and I cannot connect to the Internet - any ideas?

  mgmcc 12:37 PM 05 Sep 10

If you're trying to connect again "wirelessly", you'll probably have to delete the existing wireless "profiles" in each of the computers and go through the procedure to Connect again, i.e. scan for Available Wireless Networks, select the one that matches your router's SSID and click the button to Connect.

  peterbryant 12:58 PM 05 Sep 10


Problem is that the modem still only shows three lights when connecting to the desktop and the data light refuses to switch on still, so it is not worth connecting wirelessly yet.

Thanks in advance

  birdface 23:30 PM 07 Sep 10

Maybe Try Services and scroll down to WLAN and make sure it is set to automatic.

  mgmcc 08:14 AM 08 Sep 10

I have held back from replying because I don't have a Belkin router and don't know what the "Data" light is. As you're unable to connect with an ethernet cable, it clearly isn't just a WLAN issue.

Routers usually have a light for each of the ethernet LAN ports, which would be lit when the port is connected and blink when data is transferred. Does this happen?

There is probably a light to indicate that the ADSL connection to the exchange is active. Again, I don't have ADSL broadband to be conversant with the specifics, I have Virgin's Cable service, but is this light showing correctly?

  peterbryant 08:48 AM 08 Sep 10

Hello All,

Got the Data back online (was entering data for resetting wrongly) and once this happened, resetting the router worked a treat.

Now the internet works perfectly in my house.

Thanks very much for your help



This thread is now locked and can not be replied to.

Best Black Friday deals 2015 live blog: Best UK Black Friday deals & best UK Black Friday tech…

1995-2015: How technology has changed the world in 20 years

This 4K screen is purpose-built for showcasing digital art

20 Mac Power User Tricks... That You Didn't Know