Belkin Hi-Speed USB 2.0 DVD Creator

  Goolie 22:57 26 Feb 04
Locked

I have just purchased a Belkin Hi-Speed USB 2.0 DVD Creator. I have installed the driver (on my win xp system). Everything seemed to be working fine using the included Ulead Video Studio software, then without warning my system rebooted.
Now this is happening every few seconds that the device is connected to USB 2.0 port.
I have tried it on my other 2 systems (both running windows xp) with same results.
Can anyone help without me having to telephone Belkin tech support?

  AL D. 23:12 26 Feb 04

A couple of suggestions ,have you tried getting lates chipsets for your mobo, also have you got updates for usb2 from microsoft?

  Goolie 23:20 26 Feb 04

I am getting this problem on 3 different systems with different mobo's, so I can't see that being a problem. All updates installed.

  Goolie 18:05 06 Mar 04

I have installed latest usb 2.0 updates and drivers, and now have got the device working.
The problem i have now is that when the mpeg created is played back, or converted to a dvd-r, the result can be viewed ok but is a bit jumpy.
I have tried capturing in several different resolutions but all have the same result.
Can anyone help? (before I pull all my hair out!)

  alnwrd 20:26 06 Mar 04

I gave up on this device as the first one would only record in black and white, whilst the replacement produced poor quality results. Pinnacle studio 8 with a pci capyure board is much better

  absent 13:12 07 Mar 04

I have used this with great results, make sure you turn of any background progs, especialy anti virus.

  Goolie 18:44 07 Mar 04

Thanks for that absent, have tried with every background progs running, including anti-virus.
Still same results I'm afraid.......can't think of anything else to try.

  Goolie 19:02 07 Mar 04

sorry meant with every background prog not running.

  nominal 12:44 08 Mar 04

Can someone tell me what inputs the unit has? I'm just about to buy one, and assume one is a standard audio input, while the other receives the video signal. Is it RF (aerial input) or something else altogether? The images on their website and every description I've seen doesn't mention this at all.

  Goolie 16:57 08 Mar 04

The unit itself does not process the sound, this is connected via supplied cable to 'line in' on your sound card.
The input connectors are: S-video (small din plug) and Video (yellow phono plug). Does not use RF signal.
Would not recommend buying one unless I can sort out my problem with it!

  absent 20:57 08 Mar 04

Try capturing from another device, such as a vcr if possible. Do you have any other composite video leads to try, I paid £20 for some from Dixons (Panasonic) but got much better results with some from a lead set I purchased years ago.

Alan

This thread is now locked and can not be replied to.

Sniper Elite 4 review: Headshotting Nazis has never felt so good

1995-2015: How technology has changed the world in 20 years

The Best Design, Illustration, Animation and VFX Awards of 2017

WWDC 2017 dates: How to get WWDC 2017 tickets, when is WWDC 2017 and more details announced