Belkin G+ MIMO Router Locks up

  Squirrel1 15:44 04 Aug 07
Locked

I have a Belkin G+ MIMO router running as a stand alone wireless access point for all the computers in the house.
This has been running fine for a few weeks now, but since I have changed the security encription from WEP to WPA-PSK it will sometimes not allow access to the network with the message, on the computer trying to access the network, 'Aquiring Netwook Address', but will not connect until I pull the plug on the router and power up the router again.
This is a pain.
Is there a setting that needs addressing or is the router faulty????

  Sebby 23:09 05 Aug 07

Have you tried updating the firmware to the latest firmware? If there isn't a new version available, or even if there is for that matter, a reset to factory defaults can often sort out these bizarre issues.

  Squirrel1 19:39 06 Aug 07

No firmware up date available at this time and I did restore to factory settings. Then reinstalled the router.
Everything worked fine next morning, but later that day problems again.

Router taken back to PC World....

New router working fine......for now!

This thread is now locked and can not be replied to.

Sniper Elite 4 review: Headshotting Nazis has never felt so good

1995-2015: How technology has changed the world in 20 years

The Best Design, Illustration, Animation and VFX Awards of 2017

WWDC 2017 dates: How to get WWDC 2017 tickets, when is WWDC 2017 and more details announced