AVASoft Professional Antivirus rogue software & XP Safe Mode

  AlanPCA 11:19 AM 08 Apr 13
Locked
Answered

The AVASoft virus has infected my old tower computer. It runs on XP with free Avira antivirus. Avira warned me of a problem immediately but could not clear it. After a restart I can no longer open MS Office files, pdfs etc or start Chrome. Whilst I can start IE, AVASoft blocks access to any sites as being "unsafe". A simple System Restore will not open to get back to a restore point.

I looked at the previous post from Widdy for a solution. From the replies, I have tried the 3 fixes from Thankyoumate's link but these failed (PF8 ignored on startup, activation code box blocks typing, file rename fails). Fruit Bat posted a link to bleepincomputer.com but this solution requires a start from Safe Mode with Networking and I can't get there as PF8 is ignored (as is PF5).

The bleepincomputer.com solution says to not force Safe Mode with msconfig if PF8 doesn't work. I have looked at other posts for starting in XP Safe Mode but without success. Some say use msconfig instead of PF8 and another warns against.

It seems that without entering Safe Mode then I can't try the other fix.

Please, can anyone suggest a solution? Thanks

  rdave13 12:24 PM 08 Apr 13

I've never had to use the Kaspersky recovery disc but worth taking a look, click here. You might have to use another PC to download the iso and create a bootable disc to use on your infected machine.

  AlanPCA 21:29 PM 09 Apr 13
Answer

The AVASoft virus has been removed :o)

I created the Kaspersky recovery CD following the instructions in rdave13's link using another computer. I booted the infected PC with the CD in the drive and the Kaspersky first screen showed asking me to press any key to enter the menu. I pressed various keys during the countdown but these were ignored and the infected Windows XP started again. I shut down then restarted again. This time the Kaspersky screen did not show at all and Windows started again. This virus seems to learn and protect itself.

Then something happened....

The virus program tried to access the internet and was identified as a serious threat by ZoneAlarm firewall. I clicked to deny access. Without prompting, ZoneAlarm started to scan and "treat" the virus. This took several minutes with 6 files identified, then ZoneAlarm forced a restart. On restart, AVASoft was gone! I didn't get to try any of the solutions suggested, but thanks to all.

Advertisement

This thread is now locked and can not be replied to.

How to get free stuff for Android: Amazon Underground offers genuinely free Android apps and free…

1995-2015: How technology has changed the world in 20 years

MIT builds an awesome 3D printer that can use 10 materials at once

Apple rumours & predictions 2015: What to expect from Apple for the rest of the year – new iPhones,o…