AV screwed after system restore

  Ian in Northampton 20:22 09 Dec 10

My PC had been running slowly, often showing 100% CPU usage. As this had only started to happen within the last 2-3 weeks, I decided I’d do a system restore. What I should have thought through, in going back to a restore point 4 weeks ago, was that, in the interim, I’d uninstalled AVG 2011 and installed Avast.

I was alerted to the problem when starting Outlook, which told me it couldn’t find an Avast file. I now have the following situation:

1. AVG isn’t running – neither is Avast. Avast doesn’t show in the Programs list, nor in ‘add/remove programs’

2. AVG still shows in my ‘Programs’ list and in ‘add/remove programs’.

3. Clicking on ‘uninstall AVG’ does nothing

4. Similarly, trying to remove it using ‘add/remove programs’ does nothing – except hang ‘add/remove programs’, requiring a reboot to get rid of it

5. The AVG remover tool doesn’t do anything either – except stop – as it’s not finding any AVG files to remove.

I want to reinstall Avast – but I’m nervous about doing so as long as there are traces of AVG on my system, given the horror stories one hears.

I guess I could try installing Avast and see what happens – but I thought I’d ask the forum’s advice first.

Anyone have any ideas?

  peter99co 20:31 09 Dec 10

You are allowed to revert back to previous state by revering the restore.

  peter99co 20:31 09 Dec 10


  Ian in Northampton 20:33 09 Dec 10

Thanks Peter. I didn't know you can reverse a system restore. How do you do that?

  Ian in Northampton 20:35 09 Dec 10

I bet it's that button 'Undo last system restoration', isn't it? D'oh...

  peter99co 22:59 09 Dec 10

Run your Task Manager to check which task is over loading your system. Take time to examine the different options to measure this. If you look it allows various ways to see the culprit. Check processes and if you click image name header it will put it all in alphabetical order. Maximise the screen to see all the processes and click to leave on top while you startup. Start Task manager as soon as you can during start and you will see the picture emerging.

DO NOT end any tasks in this mode as you could create a greater problem.

Post anything unusual data finding and someone may know the answer.

It can be very busy during startup and take some minutes to settle down.

  Ian in Northampton 09:16 10 Dec 10

Well, this is getting frustrating…

I undid the system restore. Now

1. AVG 2011 is shown in Programs and ‘add/remove’ programs but it isn’t running and ‘uninstall AVG’ doesn’t work, nor can I remove it via ‘add/remove programs’.

2. Avast is present in ‘add/remove programs’ but not in the ‘Programs’ list, nor is it running.

Anyone have any thoughts?

Peter: yes, I use Task Manager for the purposes you describe. In fact, I minimize it on the ‘performance’ tab and keep an eye on it. The issue is mostly to do with Google Chrome. I’ve searched extensively, and there are plenty of reports of Google Chrome hogging the CPU, but most of them are old and/or claim to have ben fixed by the latest release of Chrome (which is what I’m running). I’ve tried various tweaks on Chrome, but without success.

I can see a system rebuild coming on…

  mfletch 09:23 10 Dec 10

Please download this to remove AVG

AVG Remover click here

  Ian in Northampton 10:10 10 Dec 10

Thanks mfletch. That worked in a way that the remover in my OP didn't - I may have downloaded the wrong version on that occasion. So, now we have AVG gone, and Avast installed - but I'm sitting here looking at the Performance tab of Task Manager and Chrome - with four windows open - continues to be the single biggest user of the CPU, with percent rarely dropping below 30% and often around 70%. For a browser that was 'sold' as being lightweight, small footprint and fast, something is wrong somewhere.

  peter99co 16:09 10 Dec 10

Get rid of Chrome. It doesn't suit my XP set up either. I had it installed along with Google Earth and I have remove that as well.

  Ian in Northampton 16:57 10 Dec 10

Peter: that would be a last resort. It used to work fine - was everything it was billed to be. Yet as I'm sitting here typing this, my CPU usage is at 100%. Perhaps I'll do a rebuild after all. It's either that or Christmas shopping...

This thread is now locked and can not be replied to.

Intel Coffee Lake 8th-gen Core processors release date rumours

1995-2015: How technology has changed the world in 20 years

Framestore’s haunting post-WWII title sequence for new BBC series SS-GB

How to install MacOS Sierra on an older Mac: Get Sierra running on Macs & MacBooks from before 2009