Autoplay for DVD drive doesn't work anymore

  Icky 11:16 15 Jan 04
Locked

Hello,
Hope someone can help.
Windows XP Home.
I've just noticed that both my DVD and DVD RW drives no longer autoplay. I don't know when this happened as I haven't loaded any more CDs until recently.
I've checked in both drives' properties and they are set to default. I've tried the other settings but with no luck.
I've looked through other threads about this and found the correct place in the registry but not sure what to change.

My registry says:

Default REG_SZ
NoDriveTypeAutoRun EEG_BINARY ff 00 00 00

Thanks for any help.

  ©®@$? 11:23 15 Jan 04

Click Start, Run and enter SERVICES.MSC Look in the right pane for
Shell Hardware Detection. This service should be set to Automatic and
Started. If not, double click it and change the settings.

Click Start, Run and enter REGEDIT Go to:

HKEY LOCAL MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom

Look in the right pane for a value called AutoRun. This value should
be set to 1. If not, double click AutoRun and change it to 1.

Next, go to:

HKEY CURRENT USER\Software\Microsoft\Windows\CurrentVersion\Policies\Expl
orer

Look in the right pane for a value called NoDriveTypeAutoRun. This
value should read 91 (145) If not, double click NoDriveTypeAutoRun and
enter 91.

  keenan 11:25 15 Jan 04
  Smiler 11:27 15 Jan 04

What dvd player program are you using? Have you checked the configuration for this program?
I use Cyberlink Power DVD and in the configuration General tab is an option to enable/disable play automatically on insert.

  Icky 11:29 15 Jan 04

Wow ---- that was quick!! Thanks
I'll try the suggestions soon.

  Icky 14:16 15 Jan 04

Ok,

I've gone to
NoDriveTypeAutoRun EEG_BINARY ff 00 00 00 and double clicked on it. In the window that pops up it says under value data:

0000 FF 00 00 00 y...

Where in that line do I type 91?


Gosh, I must be thick!

Thanks for any more help.

  Stuartli 14:23 15 Jan 04

When you insert a DVD or CD you should get a panel up asking which program, such as Windows Media Player, you want to play it?

Once you have chosen that it should do so automatically in future.

However, if you have a burning program such as Nero, then Auto Insert Notification (as it's named in earlier Windows versions) is normally disabled as Nero controls the operation of the drives; it's to do with the data first put on the blank CD-R or CD-RW.

  ©®@$? 14:30 15 Jan 04

this edit will do it for you Enable CD AutoPlay for Pro or Home (Line 10)


click here

  hugh-265156 14:32 15 Jan 04

as ©®@$? above says its

start/run type regedit click ok

navigate to:

HKEY LOCAL MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom (just click cdrom do not expand)

in the right pane look for "Autorun" click it and set value to "1" to enable or "0" to disable

  Icky 14:54 15 Jan 04

It's solved!!!

Many thanks everyone.
I ended up using the site recommended by ©®@$?

What a wonderful Forum this is.

This thread is now locked and can not be replied to.

Best phone camera 2016/2017: Galaxy S7 vs iPhone 7 vs Google Pixel vs HTC 10 Evo vs OnePlus 3T vs…

1995-2015: How technology has changed the world in 20 years

The Pantone Colour of the Year 2017 is Green

Super Mario Run preview | Hands-on first impressions of Super Mario Run: Mario's iPhone & iPad…