Auto Play doesn't work

  Pine Man 16:56 07 Feb 06
Locked

Running Windows XP with SP2

I have a CD and DVD player which both ‘Auto Play’ properly and open a window to show their files when inserted.

I also have a USB memory stick and today added a USB card reader and neither ‘Auto Play’ in that a window does not open when inserted. I have set both up correctly through properties to open Windows Explorer and also run the Microsoft Autofix.exe program. In addition I have also turned off NIS 2006 just in case it was treating the windows as ‘pop ups’. No joy.

Any ideas?

  billyliv 17:02 07 Feb 06

Start->Run...

Type in 'regedit'

Open the following:


HKEY_LOCAL_MACHINE
SYSTEM
CurrentControlSet
Services
Cdrom

On the right side, set the key named 'Autorun' from 1 to 0. Then, restart Windows.
Reverse this process. Cheers, Bill

  Pine Man 18:27 07 Feb 06

Thanks for your reply.

Checked the registry and the value for cdrom is shown as 0x00000001 (1).

Two queries first.

1. Is it the 1 in brackets that I change to 0?
2. As this is a setting for cdrom (which works ok) will it affect the behaviour of two USB storage devices which don't?

Peter

  Pine Man 19:56 07 Feb 06

I gave it a try and it didn't work. Both the CD and DVD auto play ok but still neither of the USB storage devices will.

  Joe R 20:04 07 Feb 06

Pine Man,

this may do the trick for you. click here

  Biotech 21:40 07 Feb 06

If there is no data to open then I doubt anything will happen.

  billyliv 00:12 08 Feb 06

Hi Pine Man, Changing the value to '0' will disable autorun. I may be way off beam here, but, I dont think USB supports autorun. If I want to play music etc. from a flash stick I have to D/Click on the drive letter allocated. Cheers, Bill

  Pine Man 16:41 08 Feb 06

Still not working although they used to once.

Funny old things computers!

This thread is now locked and can not be replied to.

Surface Pro (2017) vs Surface Pro 4

Where HTML5 is headed next

MacBook Pro v Surface Pro 5