Audigy 2 and ZS

  Eveready Bunny 12:41 29 Sep 05
Locked

Hey all,

My old audigy 2 gave way this morning with lots of clicking and popping this morning, thought it was my speakers by the aux port on my speakers proved it was the sound card. Anyways i used to have the old audigy 2 platinum, which has the internal drive bay thing, which i tend to use quite a bit, i was wondering if i could buy the new aud 2 ZS version and if the internal drive bay would still work, or if i would have to fork out for the more expensive aud 2 zs with the drive bay?

  CurlyWhirly 17:19 29 Sep 05

I have just bought myself an Audigy 2 ZS sound card a few weeks ago and I have no problems with clicking noises.


I *used* to get clicking noises when I used to have an Audigy 1 sound card a couple of years ago and even downloading and installing the PCI latency patch at click here didn't seem to work so I went back to onboard sound.


I have a ViA chipset by the way, if you DO have a ViA chipset perhaps it might be worth you trying to download and install this patch?


Alternatively have you tried repositioning the sound card in another PCI slot as sometimes you can cure an IRQ conflict by doing so.


Also have you gone to the Creative website and searched for the latest drivers or even sent them an e-mail explaining the problem and asking for advice?


p.s. I can sympathise with you as I know how annoying the clicking noise can be especially when online as when I used to get it nearly every website link I clicked on produced the noise!

This thread is now locked and can not be replied to.

Amazon Fire HD 8 review: A brilliant combination of function and value – with one massive caveat

1995-2015: How technology has changed the world in 20 years

How to create an introvert-friendly workplace

Apple Watch 2 review | Apple Watch Series 2 review: New Apple Watch is faster, brighter, water-resit…