ATI Drivers not installing :( - Makes me sad

  GibsonSt19 23:54 30 Jul 04
Locked

Evening, I wanted to upgrade my ATI Radeon 9800 Pro GDx Card drivers today and followed instructions on click here on how to use CAT Uninstaller, or Driver Cleaner 3 to remove the remnants of the old driver before installing.

I downloaded the WHQL drivers (CAT 4.7's) however when I run the install EXE, I get a message which says "Setup was unable to find components that can be installed on your current Harware of Software configuration. Please make sure you have the required hardware or software.

Now, I've tried to find answers via google, however none of the suggestions contained in any of the links found work. :(

Any ideas?

I've not had System Restore enables, so I can't restore to yesterday for example, and I'm unable to roll back the drivers for some reason.

I think I may cry

  helmetshine 07:08 31 Jul 04

I had a similar problem a while ago....i managed to solve it by reinstalling the original drivers from the disc that came with the card and then updating again without using either drivercleaner or the ATI uninstall tool.....i just followed the advice given on the ATI siteclick here

Basically they say to remove the current driver and control panel using Add/Remove Programs...reboot when prompted....cancel out of the Found New Hardware wizard and double click on the new driver you have d/loaded.Since doing it this way i've updated the driver a number of times with no problems

PS don't use the new hardware wizard to reinstall the original drivers from the disc either

  GibsonSt19 11:19 31 Jul 04

Trouble is, is that's it's an original ATI card, not powercolour or saphire. I've tried following the instructions on the ATI website, however with no joy. I just can't seem to get the drivers installed any which way :(

  GibsonSt19 15:11 31 Jul 04

Anyone have any advice?

  woodchip 16:11 31 Jul 04

Load your old drivers and then run the download for the new drivers, if it's a zip file unzip first then run setup, it should have it's own uninstaller built in

  GibsonSt19 16:28 31 Jul 04

But I don't have the old drivers. I binned them on account of them being pants :(

  woodchip 16:29 31 Jul 04

Then you may be up the creek

  woodchip 16:33 31 Jul 04

What you could do is this Go to Device Manager after you have unziped the drivers, Double click display Adapter Ati check each tab and look for the update drivers tab then point it to the unziped files

  GibsonSt19 17:17 31 Jul 04

Tried this mate, get same pooey message Arrrrrggggg

  woodchip 18:14 31 Jul 04

If it is not accepting drivers in Device Manager then they may be the wrong drivers. Or You can try forcing it to load the drivers if you check it right

  GibsonSt19 18:28 31 Jul 04

I definately have the right drivers. Catalyst 4.7's, straight from the ATI site, for my Radeon 9800 Pro. Actually, it does let me install them, but they just don't stick.

This thread is now locked and can not be replied to.

Best phone camera 2016/2017: Galaxy S7 vs iPhone 7 vs Google Pixel vs HTC 10 Evo vs OnePlus 3T vs…

1995-2015: How technology has changed the world in 20 years

Best Christmas Agency Projects of 2016

Super Mario Run preview | Hands-on first impressions of Super Mario Run: Mario's iPhone & iPad…