Aspire One Not Booting After Being Flooded

  Shark boy 14:31 14 Mar 10


My aspire one is not booting after the floods in November last year. It has been given around 4 months to dry in a well aerated cupboard.

I took it out on Firday to see if it would work, so I got the charger and plugged it in. Miraculously, I got the charger light to come on, then it went off again. I gave the socket a blow, then tried again. It worked this time, giving a straight orange light. I pressed the on button, and it went green. The screenn gave a quick flicker, then the machine went dead again. This is all I can do. Any ideas?

Suggestions will be brill,

Shark boy

  Fruit Bat /\0/\ 14:55 14 Mar 10

Claim on your insurance

  Fruit Bat /\0/\ 14:56 14 Mar 10

try with battery removed., but I don't hold out much hope.

  Shark boy 21:26 04 May 10

ta, i've given up. took the back off it, found several switches on the motherboard dead and drowned.

RIP Aspire One.

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

Method Studios' title sequence for BBC series Taboo is truly unsettling

Best Pages for iOS tips | How to use Pages for iPad & iPhone: 7 simple tips to get more out of…