Anyone tried Firefox 10?

  Muergo 23:25 PM 23 Jan 12

Firefox 10 is now up to Beta 5 and I was thinking of switching as FF9 keeps crashing and autorestarting, a problem I had with FF7.

Strangely I'm having the same trouble with Internet Explorer, the PC is very clean, all the security has been run and Secunia gives 100%.

  birdface 23:36 PM 23 Jan 12

If it is this one you mean Firefox 10 Aurora,I tried it but got fed up with the constant updates and went back to the 9.0.1 version.

  Muergo 23:53 PM 23 Jan 12

Update doesn't say anything about Aurora. Just listed as 10 Beta 5, from what I see of previous issues they seem to get up to Beta6 and then get launched as a full update.

  birdface 01:00 AM 24 Jan 12

Ok.looks like it may have been a different version of Firefox that I was using so cannot comment on the beta version although it looks Ok with better protection against nasties.

  Input Overload 09:35 AM 24 Jan 12

FF isn't that unstable & should not keep crashing, I run a derivative of FF 9.01 - Pale Moon & in weeks of running it I can't remember it ever crashing.

The fact that IE does the same thing would seem to point to issues in your install. Have you run a scan with the free version of Malwarebytes Malwarebytes Site on checking others PC's I often find this anti-malware program often finds problems that eludes other AV's.

  cocteau48 09:51 AM 24 Jan 12

I have been running FF10 throughout its program of beta releases on my test laptop. Absolutely no problems whatsoever.

I initially installed it to keep a check on the compatibility of by add-ons and thus far all are working - with the exception of the Evernote Web Clipper which is always the last to catch up.

  Salut 16:15 PM 24 Jan 12

I switch to FF about a year ago and keep up to date with the Beta releases. safe to say absolutely no problems. I used to use Opera but gave up...

  Muergo 13:16 PM 25 Jan 12

Right OK will switch to FF10 Beta 5 as Firefox 9.01 still going through fading misty screen saying "Firefox is not responding". Maybe it's one of my addons but then it wouldn't happen with I.E. as well, alternatively I might have too many windows open.

Can't possibly be a bug as all zappers have been run , Malwarebytes, SAS etc in addition to Windows7 security essentials and checked with ASC. All show nil result apart from Ad cookies which are deleted regularly.

  Muergo 13:25 PM 25 Jan 12

Today it has jumped to FF beta 6 so must be nearly there, I have downloaded it, looks a bit smarter than before, no problems with any of my add ons.

  iscanut2 14:56 PM 25 Jan 12

I have been running the version 10 betas without any problems at all.


This thread is now locked and can not be replied to.

The 14 most useless gadgets of all time: nauseating, crappy and downright silly technology, from a…

1995-2015: How technology has changed the world in 20 years

Google Maps for web gets a Material Design-inspired makeover

New Apple TV 2015 release date and UK price: buy from Apple in late October, in store in November