Anti virus unable to update/install

  geoff47 19:43 PM 03 Oct 12
Locked
Answered

I had AVG installed but when an update to the next version was due the update failed because I didn't have enough administration rights. I checked, and was Administrator. I then removed AVG and downloaded Avast, same thing happened. I then downloaded the new AVG 2013 free and went through the install process, which failed again. The advice given was to reboot and try and install again, same thing happened.

Any advice ? I am now without antivirus.

  Nontek 20:02 PM 03 Oct 12

A friend of mine had similar problems very recently, my friend eventually found that the problem was caused by a Trojan, possibly more than one. MalwareBytes eventually got rid of it, by running a full scan in safe-mode.

  northumbria61 20:03 PM 03 Oct 12
  geoff47 21:52 PM 04 Oct 12

I now only have internet on my Linux PC.

I found I had AVG on my PC still , although I had used Revo Uninstaller. I uninstalled again, tried to reinstall, then rolled back and tried again. I did a safe mode full scan with Malwarebytes, which took no time at all.........surprisingly, so I did it twice.

Anyway I managed to install Avast, but when I next booted up, NO INTERNET. Have done all the scans to check. When opening a browser, nothing, open up Network settings and ask for a repair and it takes forever, and all I get is a red crossed icon and no connection.

Is it the same problem, or have I got another one ?

  Nontek 21:59 PM 04 Oct 12

Sounds like you have a nasty, maybe more than one. Turn off System Restore then try Malwarebytes again in safe mode. The scan should take some time, depending on how much data you have on PC.

Don't forget to turn on System Restore afterwards.

  Fruit Bat /\0/\ 23:01 PM 04 Oct 12

more than one AV will conflict

AVs are difficult to uninstall on purpode to prevent naxties from trying to uninstall the Av in order to inflict damage. therfore most AVs need a proper uninstall tool to get rid of them before trying to install another AV.

Use the Avast uninstall tool

and the AVG uninstall tool

then reinstall the AV of your choice

  geoff47 10:56 AM 06 Oct 12

I have downloaded and used the tools to rid my PC of both AVG and Avast, so I am totally Antivirous free. I attempted to run Malwarebytes, but it said it was 'corrupt' or needed update, but as I cannot connect it couldn't update. I uninstalled Malwarbytes, then downloaded and re-installed it via Slax on the same PC, but still couldn't update it,and it didn't find anything. I have uninstalled the ethernet card, so it re-installs after re-boot. All the hardware is working, because that is what I am connecting with to write this, using a live disc running Slax.

Anyone out there got any ideas where to go now ?

  Fruit Bat /\0/\ 14:57 PM 06 Oct 12

What version of windows / browser / firewall?

windows / drivers - Check in device manager no exclamation marks against ethernet drivers

try disabling the firewall to see if you can then get through.

  geoff47 18:12 PM 06 Oct 12

I have windows XP Professional, am using Commodo Firewall and use Thunderbird but no other browser/program will connect. As soon as I try to connect I get two monitors icon with a cross to show I have no connection, clicking repair doesn't help. I shall try again with no Firewall.

  geoff47 18:42 PM 10 Oct 12
Answer

I have no idea how I solved this problem, but everything is alright now.

Just to summarise what happened. My Antivirus AVG wouldn't update to the current version, telling me I didn't have enough privileges. I tried to change antivirus, but Avast wouldn't install either. I uninstalled and tried to reinstall AVG but by then my internet connection wouldn't work, showing as two monitors with an exclamation mark beside it and telling me no or limited connection, and it would not repair itself as usually does.

I then followed advice and used a live disc with Slax on it to connect and downloaded the uninstall programs for both AVG and Avast, then cleared them all off my machine. Still couldn't connect though, despite checking all my settings and uninstalling my ethernet card, so it could reinstall when rebooting.

Anyway next time I logged on, everything was working. This might help somebody, if only to understand PC's are moody. I installed Microsofts PC Essentials, and it appears to be working better than before, I have cleared a lot of rubbish off the PC also.

  Nontek 18:57 PM 10 Oct 12

Thanks for your feedback - I assume you meant to say Microsoft Security Essentials (MSE), I have used this since it first appeared on the scene and I think it is great.

Advertisement

This thread is now locked and can not be replied to.

Sony Xperia Z5 vs Xperia Z5 Premium vs Xperia Z5 Compact: What's the difference between Sony's new ?…

1995-2015: How technology has changed the world in 20 years

Get $800 of free online Nuke and VRay rendering from Google Zync

iPhone 6S preview: What to expect from Apple's next iPhone