another dead un

  britto 20:58 20 Sep 06
Locked

I have a friend’s emachine 620 which will not start and would appreciate any advice it has an Alaska? Motherboard and a Intel Celeron 2.7ghz processor, the Psu will not work while plugged into the board but will when tested out of the machine, Disconnecting the motherboard and connecting the green and black on the main plug lets the psu run and gives power to all smaller plugs letting the dvd and cd drives open and close but only if the ide cables are disconnected, is the board and or the processor kaput
I cannot see anything obviously wrong
cheers, britto

  Jak_1 21:01 20 Sep 06

ounds like the PSU is on its way out, not enough power for the mobo.

  britto 21:06 20 Sep 06

Jak_1 thanks for the reply tried it in another comp and it booted it up although not an intel one if that makes any difference?.

  STREETWORK 21:13 20 Sep 06

If the PSU is running and the fans operating the problem could be with a memory card.

If you have 2 memory cards? If so take one out at a time and try to reboot. This will eliminate memory problems and could point to the CPU

  britto 21:22 20 Sep 06

STREETWORK
Tried it with everything but the cpu/fan stripped out and would still not kick in thanks

  STREETWORK 21:25 20 Sep 06

In this case it needs a tech to test it.

This thread is now locked and can not be replied to.

The Legend of Zelda Breath of the Wild review: Five hours with Zelda on the Nintendo Switch

1995-2015: How technology has changed the world in 20 years

How the painting-like animated sequences in A Monster Calls were created by Glassworks Barcelona

The 22 best Safari extensions | Best Safari plugins: Improve Apple's Safari web browser with these…