amilo pro v2055 533mhz memory

  junglej 09:05 17 Jan 12
Locked

Have purchased 1GB module and tried using it with the 1GB module already inserted. But notebook just beeps and screen is dead. Tried it on its own also and its still the same. Notebook works with old memory in either slot. What is causing this?

  onthelimit1 10:54 17 Jan 12

It sounds like wrong RAM.. Did you use the Crucial scanner to check?

  onthelimit1 10:55 17 Jan 12

P.S.

According to Mr Memory, it should be 200 Pin SODIMM DDR2 PC2-4200 533MHz

  KRONOS the First 10:56 17 Jan 12

Is the RAM exactly the same as the original RAM? If so it is more than likely that you have a faulty module,it happens,particularly as the laptop does not seem to work with the new ram in.

Where did you get your RAM from,how did you know what RAM to buy?

  junglej 06:48 18 Jan 12

I did a check to see what ram I could use and have added memory before. So should have been straight forward, but have now tried two modules, both the same make 'Corsair' and both the same outcome.

  junglej 06:51 18 Jan 12

Ram module in at moment is PNY 1G 200 pin sodimm pc2400 533 Mhz

This thread is now locked and can not be replied to.

Qualcomm Snapdragon 835 benchmarks: Antutu, Geekbench 4, GFXBench and PCMark results

1995-2015: How technology has changed the world in 20 years

This stop-frame animation tells a moving story of domestic violence for Refuge

New iPad 2017 preview: Apple's affordable but underspecced new iPad may appeal to the education…