Amiga advise needed

  AMD 4 ever 15:53 13 Apr 03

I am having trouble conecting the Amiga to my TV. I have the power cord, the LED comes on and then graphics port has a funny adapter on it...Whic i assume then connect the RF out to the TV RF in port on the TV...Any clues?

  A15 16:20 13 Apr 03

I assume you are talking about an A500........

It's been a few years since I had a play with one of those!!!

If I remember correctly though you need a convertor in order to plug an Amiga into a TV. I used to use a monitor, but did have the adaptor, which plugs into the back of the Amiga then as you say rf out to rf in on TV, which you would then have to tune to the correct rf frequency.

  AMD 4 ever 16:37 13 Apr 03

You wouldn't believe I got i and about 20 games from a car boot sale today for £3...I snatched and ran with it. I have the adapte just needs to be selected on the right frequency, i think where i was going wrong was I just left it on AU.

  Forum Editor 19:53 13 Apr 03

and A15 is right.

  Megatyte 20:07 13 Apr 03

The TV will need tuning in to the right frequency. The chances are that the modulator is transmitting on channel 36. Be sure to disconnect your aerial as channel 5 broadcasts around this frequency(channel 37 where I am) and may cause interference.


  bloo meeny 22:28 13 Apr 03

Agree with all the above - the RF modulator also had a little switch at the side, if NO video at all check setting.
The connection for TV aerial is the one at the END of the modulator. The others are a 'composite' output to a monitor (or video) and an audio INPUT - designed to be fed via a small "Y" lead from the L & R outputs on the A500.

I still have my A500 (and a Dragon32) and a friend has the A500+ and A1200 !!!

  bloo meeny 22:39 13 Apr 03
  A15 00:21 14 Apr 03

That brings back a few memories.

I loved the specs at the bottom. Just to think a 7.14mhz processor & that was all the rage but a few short years ago!..............

  davidg_richmond 01:20 14 Apr 03

i have a working modulator available if needed (unless it got chucked out at my parent's house). the amiga 500+ there simply won't display video with/without the modulator. probably something to do with 'fat agnus', the lazy cow!

This thread is now locked and can not be replied to.

Nintendo Switch (Nintendo NX) release date, price, specs and preview trailer: Codename NX console…

1995-2015: How technology has changed the world in 20 years

8 things designers (and brands) need to know about the modern woman

How to speed up a slow Mac: 19 great tips to make an iMac, MacBook or Mac mini run faster | Speed…