AirGCFG.exe - Entry Point Not Found

  gibbs1984 13:21 22 Aug 07
Locked

Hi, I found this thread - click here - but it's been resolved.

I am getting the following error messages when logging in Vista Home Premium, I've searched the web and found that it's to do with the wireless D-Link that I have installed but I can't find any solutions on how to fix it, was wondering if anyone had any ideas or new of any websites that offered advise.

Error message:

AirGCFG.exe - Entry Point Not Found
X The procedure entry point apsGetInterfaceCount could not be located in the dynamic link library wlanapi.dll
&
WZCSLDR2.exe - Entry Point Not Found
X The procedure entry point apsInitialize could not be located in the dynamic link library wlanapi.dll
I presume these 2 are part of the problem also - Can anyone help?

Thanks,

Steve

  gibbs1984 13:03 26 Aug 07

An ideas anyone :o(

  Ashrich 21:48 26 Aug 07

The software that comes with the card is not ready yet for Vista , and this is what is causing the problem , uninstall the D-Link software and try loading just the drivers , if you tell me the exact model of wireless card I can probably find the correct driver for you . If you can actually access the internet but are still getting these error messages you can go into Windows Defender and disable the two programs and that will stop the annoyances and may speed up your connection as well .

Ashley

  gibbs1984 12:44 27 Aug 07

Yes, I can still access the internet although it is slower than normal, I have been into Windows Defender but can't see how to disable the two programs.

Am I disabling the two .exe files or disabling D-Link from Windows Defender?

It's D-Link Wireless ver 3.00, DWL-G122 AirPlus G Wireless USB Adapter.

If you need any other information then I will try to get it for you.

Thanks for your reply.

Steve

  Taff™ 20:35 27 Aug 07

Try click here= for the drivers. Make sure it is the correct version which is on the back of the adapter. If not go to the home page and select Technical Support which will take you to where I found these.

  Ashrich 00:07 28 Aug 07

Ok , sorry I'm so late replying , been out all day ...if your v3 USB adapter is a B1 or C1 type , download this driver click here

Remove ( un-install ) the D-Link utility , it may leave the working driver behind , if it doesn't , then use the one you have just downloaded , it is Ralink , the manufacturer of the chipset used in your device , and let Vista manage the connection instead of D-Link .

Ashley

  Ashrich 00:24 28 Aug 07

For disabling in Defender , go to Windows Defender/Software Explorer , find the two .exe files in the right hand column , then using the drop down box , click " show for all users " , that will activate the remove , disable and Enable buttons , highlight the .exe file you wish to disable and then click the correct button .

Ashley

  Taff™ 08:50 28 Aug 07

Interesting thread but it`s not clear to me which driver you refer to on your link - there are several.

  gibbs1984 11:24 28 Aug 07

Hi,

Thanks to everyone that has replied, I will try this tomorrow as I'm at work at the moment and I'm at football tonight.

Thanks again, I'll let you know the outcome.

Regards,

Steve

  Ashrich 19:42 28 Aug 07

Sorry , should have said , second one down , for the RT2571/RT2500 ( Ralink ) driver USB .

Ashley

  gibbs1984 23:42 30 Aug 07

Hi,

I installed the second one Ashrich as you said but it hasn't done anything, I now have a Ralink Wireless LAN Card (Not exist) icon in my start up tray.

I still gets the errors.

Taff, I installed the one you suggested but all it did was uninstall the D-Link and then I had to install it again.

Not sure what I'm doing wrong here.

It is a C1 type btw.

Regards,

Steve

This thread is now locked and can not be replied to.

Surface Pro (2017) vs Surface Pro 4

20 groundbreaking 3D animation technologies coming to Siggraph 2017

iPad Pro 12.9 vs Surface Pro 5