AGP card won't announce itself

  daba 16:44 10 Feb 08
Locked

Putting new mobo into existing PC, had to buy a AGP graphics card (the other mobo had onboard graphics).

Inserted graphics card and powered up PC, but the card doesn't "sign-on", and the monitor reverts to power-saving mode, as though it is getting no signal.

The mobo is an ECS K7S5A, and is known to be in working order (had it in my PC until recently), and the new graphics card is an Radeon 9250, which is an 8x AGP. The Mobo doesn't have on-board graphics, so the BIOS should be set correctly to use the AGP slot. The Mobo only supports 4x AGP, but AGp bus speeds are always backwards compatable (so I have read).

Any idea what could be the problem

  woodchip 16:49 10 Feb 08

I think the mobo only supports 4 also Volts may differ

  daba 17:25 10 Feb 08

Yes woodchip, I've done some research, and as i said bus speeds are backwards compatable.

As far as Volts, I've read that the keying (slots in the edge connector) determines the voltage compatablity, adn that if the card goes in the slot, it is compatable.

I think my next step is to try another graphics card, possibly swap out the one from this PC.

  daba 21:49 17 Feb 08

Sorted now - turned out to be a mechanical problem.

The card just hadn't bottomed out into the slot properly, the retaining "bridge" being just too far above the height of the MoBo.

Cured by re-installing MoBo with 1mm spacers, this was enough to allow the AGP to sit properly in the slot.

This thread is now locked and can not be replied to.

AMD Ryzen release date, specifications and features: Three CPUs from the Ryzen 7 range now…

1995-2015: How technology has changed the world in 20 years

How the painting-like animated sequences in A Monster Calls were created by Glassworks Barcelona

Best iPhone games 2017 | Best iPad games 2017: 162 fantastic iOS games that you need to play right…