ADSL Modem not loading in Windows 98SE

  bigfella 23:18 04 May 04
Locked

I recently subscribed to Tiscali's broadband and they sent me a Sagem FST800 modem. When loading the drivers in Windows 98se all seems to load okay but when finished there is no sign in control panel of the new modem and the only evidence is in the network adapters where there is a new adapter but with an exclamation mark next to it. No idea what is going wrong and Tiscali are no help whatsoever. They insist I take my pc back to the supplier to have it checked out. I've downloaded the latest drivers off the sagem website but still the same problem.

I'm trying to cancel the subscription at the moment as I'm stuck for help.

Any clues to what is going wrong would be great.

  Diodorus Siculus 23:41 04 May 04

Don't know what is going on but would suggest you get all the relevant updates from windowsupdate.com and see if it helps.

  jocko 01:15 05 May 04

I'm experiencing simular connectivity problems in Windows98SE with Tiscali as well(their helpline useless) but I feel it could be something do with USB2.0 or Chipset/Bios problems

  xania 08:58 05 May 04

Some of your OS could be corrupt. If your installation of Windows is getting a bit tired, it might be worth while doing a complete re-installation - its amazing what that can clear up. As a half-way house, you could try reinstalling over the top, but that will only clear up some errors - many dll's won't reinstall if they're already there.

  Confab 09:37 05 May 04

Did you follow the installation instructins to the letter? I'm sure you need to install the software first before plugging the modem in. Did you do this? Perhaps try uninstalling the drivers and reinstalling again.

I had a similar problem,with an etec ADSL modem on win98se,cured with a reinstall of win98se.I also cocked it first install,by installing the modem before the software.

  Gongoozler 10:06 05 May 04

I installed the same modem in my Windows 98se computer with absolutely no problems, I also installed it in another computer when I burnt out my processor (no connection between the two). You do have to install the software before fitting the modem.

  wee eddie 21:08 05 May 04

your usb need to deliver 500ma for the modem to work.

I believe that some of the earlier usb ports were unable to deliver sufficient "amps"

Check your manual.

  The Mills 23:12 04 Dec 04

The problem was resolved by a full reload of windows

  Pazuzu 03:51 07 Dec 04

I am having similar problem with Win98 & a Speedtouch 330 modem.Tiscali "help" ??? want me to contact the PC supplier or update to XP (ha ha only 64 Mb RAM).
When I do upgrade I will be looking for a broadband provider which actually offers useful support. The Tiscali forums are not active on their site.
At the moment I am contemplating re loading operating system for the fifth time.
The internal dial up modem can be seenin Device Manager, but the USB cannot. I note that Alcatel Class Registry Bus can be seen in device manager on the other PC where USB modem works fine, but not on the problem PC device manager.

  xania 08:48 07 Dec 04

If you're using Win98, USB is not supported - you need WIn 98SE for this to be supported. Even for Win 98, 64 Mb RAM is pretty close to the wire, but you should find that you can upgrade your memory without too much trouble.

PS I doubt you'll get too many responses now that stream has been closed. Suggest you open a fresh one with a link to this if you need more advice.

This thread is now locked and can not be replied to.

Best phone camera 2016/2017: Galaxy S7 vs iPhone 7 vs Google Pixel vs HTC 10 Evo vs OnePlus 3T vs…

1995-2015: How technology has changed the world in 20 years

These are the Best Christmas Ads and Studio Projects of 2016

Super Mario Run preview | Hands-on first impressions of Super Mario Run: Mario's iPhone & iPad…