ADSL Filters

  martytoon 10:39 13 Jun 09
Locked

I've had to replace the filter twice in the last couple of months. This morning with terrible hissing on the phone line it appears another one has given up on me. I've used cheap filters and more expensive ones - any ideas as to why this is happening?

  Stuartli 10:50 13 Jun 09

If they have failed so quickly, I would suggest that you take them back for free replacement (Unfit for purpose).

I've only had one fail in more than three years - my broadband speed dropped by two or three Mb for no apparent reason.

Tried various remedies and, eventually, tried a new ADSL filter/splitter at the Master Socket, which returned the full "up to 8Mb" standard.

Some interesting info on the quality or otherwise available for such products:

click here

  Stuartli 10:57 13 Jun 09

Also see:

click here

if you ever decide to fit a ADSL filtered NTE5 faceplate.

  baldydave 12:35 13 Jun 09

When you replace the filter does the hiss disappear straight away?
The reason i ask is we had a problem with random hiss,and it turned out to be a problem with a phone line crimp connector when it go damp,bt came and cut off the old crimp then put a new one on,this cured the problem.

  martytoon 15:10 13 Jun 09

baldydave
It's definitely filter related, when phone's in use the broadband connection will drop out. I got last filter from PCWorld and I've managed to find receipt so am going to see if they'll exchange it.

  Muergo 18:43 13 Jun 09

Easiest to install is buried in Stuartli info, the I plate costs about £5 and is a BT patent but available from many suppliers, provided you have a split face master outlet. It just plugs into socket behind face plate, no change in wiring needed.
BUT it did not do anything for me, the biggest improvement was from my ISP changing my profile settings, I lost some speed but gained reliability. You can't do this yourself.

  Stuartli 23:48 13 Jun 09

The BT iPlate is only of benefit in some instances. See:

click here

particularly under the Please Note section.

  Muergo 12:30 14 Jun 09

Yes, I did say that the best solution was done by my ISP ,I have been monitoring speed and dropout many times a day, and the TalkTalk guy Alan regularly rings me first thing in morning to ask how things are, I seem to be getting priority treatment, but it is down to interference he says, though one computer in this house is hard ethernet wired into modem/router.

  Stuartli 12:42 14 Jun 09

As, like me, you are with TalkTalk, have you ensured that your MTU is configured at 1432?

If not it can cause problems. See:

click here

click here

  anchor 08:57 15 Jun 09

I had a similar problem with hiss. After doing some research I found that these brand of filters were probably the best available. Ordered them, and no problem since.

click here

  cheekybaldy2 22:32 13 Dec 09

Hi all, can anyone help please?
I've had a laptop connected wirelessly to the router upstairs for a year now. But all of a sudden the connection went down. On the laptop task bar it stated that it was connected at full strength to the router. However I removed the filter and all worked ok. I tried a brand new filter and it still only works if there isn't a filter in line. The set up is - outside line into phone box - filter - double adapter with upstairs line and room phone.

This thread is now locked and can not be replied to.

Surface Pro (2017) vs Surface Pro 4

20 groundbreaking 3D animation technologies coming to Siggraph 2017

iPad Pro 12.9 vs Surface Pro 5