Adding win98 to existing network

  Rockarch 07:05 21 Feb 05
Locked

I am adding a win98se pc to a network run with a Belkin adsl router. The win98pc will be wired to the network. I have configured the network properties as instructed by Belkin and there is some connectivity as I can browse the web & get emails. However, in network neighbourhood there is only the icon for the win98 pc. I have enabled the file & printer sharing & then shared a file.TCPIP is set to obtain an IP address automatically.
When I boot up I get the windows logon screen and as no users have ever been set, I just ok the 'default' user. Is it something to do with this?
Any ideas?

  FelixTCat 08:13 21 Feb 05

Check that it has the same workgrop name as but a different computer name from every other PC on the network.

  LeadingMNMs 11:20 21 Feb 05

If I remember correctly you have to logon properly for the network to work. So you'll need to set up a user account from control panel and login using that.

If that doesn't do it then you might need to check any firewalls that your running to make sure there not blocking network traffic from the Win 98 machine.

  LastChip 11:22 21 Feb 05

You cannot join a network without logging on.

You need to set a user and log on password for Win 98 to work.

You should be able to re-boot your machine and when you get to the log on box it should already have a user in there. Choose a password click OK and you will get a second box asking to confirm the password; repeat the same task, click OK and you should log on.

  Rockarch 16:57 21 Feb 05

Thanks for the points above - I have discovered that logging on with teh default user is fine and I can see the network. However, when the win98pc is on the network, access is denied to the win xp one. Could it be that the win98 is using NetBEUI and the XP IPX/SPX to connect to teh network so the two are incompatible? If so then I can add IPX/SPX to teh win 98 one. When I tried to do this before, it asked for the win98 setup CD - as this PC had the OS installed when I got it, I only have a recovery CD - would this do the trick ??

  LastChip 18:32 21 Feb 05

You certainly don't need IPX/SPX at all.

First, until you get the network running properly, disable any Firewalls (including the built in one in XP).

Incidentally, make sure you have at least one drive or file set to share on each machine. Now re-boot the machines and try again.

If you still cannot access the XP machine, set up a user account on the XP machine identical to your Win 98se machine. So for example, if your user name is BillandBen, and your password Flowerpot, that's what you would use on the XP machines new user account.

Now see if you're in business.

  Rockarch 18:56 21 Feb 05

I'm not entirely sure whats going on. As the office needs to keep working I'm not going to be able to do anything more until the 5m network cable I've ordered arrives. So then I'll try the suggestions and post back here what happens.

I don't think I explained properly in any case. When the win98 machine connects to the network, it sees & can access files on the XP machine.
At that time if I try & explore the network on the XP machine I get an 'access denied - you do not have the right permissions' message. As soon as I disconnect the win98 machine, the XP machine is allowed on the network again.

  Rockarch 09:37 26 Feb 05

Back again - got the new bright green cable & all hooked up. Here is what happens now:
win98pc recognises its on the network and can see shared files on XP pc.
XP pc shows win98 pc in network but when I try & access it I get the following : \\computername is not accessible. You may not have permission etc. The network path is not found.

I have the same user name & password on both pcs, file & printer sharing enabled, both have same workgroup name but different computer names, so I think I've taken care of the obvious stuff.
Do I have to map a network path or something on the win98 pc?
Any suggestions please?

  LastChip 13:11 26 Feb 05

First. Please confirm you have shared an individual file or drive on the '98 machine.

Second. Make sure you have NETBios enabled over TCP/IP. This should happen automatically and will very likely be ticked and "greyed out".

You don't mention about any firewall. I repeat, until you have this problem resolved, DISABLE any firewall.

Finally, if the above doesn't help, open the registry, and find the key;


HKLM\SYSTEM\CurrentControlSet\Control\Lsa\restrictanonymous

Make sure it is set to zero; 0

  Rockarch 13:38 26 Feb 05

Thanks Last Chip - I realised I have been a twit. I forgot that there was a firewall on the win 98 machine so I've just been and had a look at it and miraculously ticking the box to allow others to share files makes it work!
The only slightly odd thing I'm left with now is that there are 5 shared folders on the xp machine but the win98 machine only sees 4 of them. I am going to take off the sharing, put it on again, reboot & see if that makes a difference but can you think of anything else it could be?

  LastChip 13:43 26 Feb 05

Check the share permissions on the file you cannot see. make sure it's not a restricted permission.

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Hands-on with the Star Wars fighting drones you can fly yourself

15 macOS Sierra tips | How to use macOS Sierra: Secret tricks and best new features in Apple's new…