adding iTunes to autoplay

  Kate B 10:11 03 Mar 04
Locked

I've got various annoying music players available for autoplay - Windows Media Player, Real One, Music Match but not iTunes, which is the one I'd like to open when a music CD is inserted into the drive. Can anyone tell me how to do this please?

  temp003 10:26 03 Mar 04

Try this first. In iTunes, click Edit, Preferences. General tab, tick Use iTunes as the default player for audio files. Then above that, against "on CD insert", select "Begin Playing". Click OK. You may or may not have to restart for this to take effect.

If this doesn't work, you'll have to associate the file extension .cda with iTunes.

  Kate B 11:17 03 Mar 04

thanks temp003, it's already supposed to be the default player ... how do I associate .cda files with iTunes?

  temp003 16:32 03 Mar 04

In My Computer, click Tools, Folder Options, File Types tab. In the table of registered file types, you can see the file Extensions and File Types. Scroll down to find "CDA Audio CD Track". Highlight it. Then in the bottom half, against "opens with", click "Change". A list of applications will appear. Select iTunes, click OK, and OK again.

  Kate B 23:01 03 Mar 04

Thanks temp003 - actually it's already associated with it. the problem is that iTunes is just sitting dumbly when I stick an audio CD in the drive ... it's only after I fire up Soundstream that iTunes wakes up, queries the CDDB and offers to rip the CD ... I've been through all the troubleshooting steps suggested by the Apple support site and still can't fix it.

Any ideas, anyone?

  temp003 00:42 04 Mar 04

If you have also already selected on CD insert, Begin Playing, then no more ideas.

This will bump you up for others to read this thread.

  Kate B 16:47 04 Mar 04

thanks for your input, much appreciated temp003

  JGG 18:23 04 Mar 04

Kate B

This is a bit of a long shot but here goes!

Do you have 'XPlay' installed as well as iTunes? (XPlay is an additional utility to use with the ipod)

The reason for asking is that I was having more or less the same problem... in my case iTunes would not autoplay the CD until I had opened it with WinDVD Recorder, then it would open and show up in iTunes. I played around with the settings and could not get it to work until I updated 'Xplay' to the latest version. It now works ok.

  Kate B 18:32 05 Mar 04

JGG - aaah, I do have Xplay installed - I'll update it, thanks for the tip. It was the best iPod software for Windows until Apple released iTunes.

  JGG 19:03 05 Mar 04

Kate B

Glad to be able to help!

I noticed that Xplay worked well until I downloaded an updated version of iTunes and then Xplay lost functionality, they previously co-existed ok. You may have noticed that Xplay stopped working when you installed or updated iTunes? ..the Xplay update installation should now allow the use of both ITunes and Xplay. I agree, Xplay is a nice little tool.

Best wishes

Jeff

  Kate B 11:49 06 Mar 04

Jeff, just done the Xplay update and bingo! I would NEVER have thought the two might not be co-existing, so thanks very much indeed for that.

Kate

This thread is now locked and can not be replied to.

Best phone camera 2016/2017: Galaxy S7 vs iPhone 7 vs Google Pixel vs HTC 10 Evo vs OnePlus 3T vs…

1995-2015: How technology has changed the world in 20 years

These are the Best Christmas Ads and Studio Projects of 2016

Super Mario Run preview | Hands-on first impressions of Super Mario Run: Mario's iPhone & iPad…