ACER TRAVELMATE AND PACKARD BELL BLANK SCREENS

  barrybolton 03:30 25 May 09
Locked

Today i took my acer travelmate laptop apart to fix a power socket problem on the back because it was loose so got the soldering iron out and managed to fix it but after putting it all back together and powering on all i get is a blank/black screen, and i cannot get into any options like F2 or F8 F12 i have checked to make sure the screen is connected properly... So i took a hard drive from my other packard bell laptop and put it in the acer and it was the same blank/black screen, so took the hard drive back out and put it back in the packard bell and cannot get that working properley now, as it boots up it shows the packard bell logo and gives me options like F2 F12 so i went into F2 and loaded set-up defaults and save and exit now whenever it starts to try and boot up all i see is a flashing - minus sign in the top left corner of the screen, can anybody help please as they both worked today thanks for any advice or help you can offer..
BARRY
P.S.
The same thing happened to another acer travelmate 2200 a few weeks ago after removing the HARD DRIVE, BLANK/BLACK SCREEN

  Technotiger 08:50 25 May 09

Did you perhaps overlook replacing the hard drives connection to mobo?

  barrybolton 10:19 25 May 09

Did you perhaps overlook replacing the hard drives connection to mobo?

Hi yes checked that as it just takes a little push to connect in to the laptops

  Technotiger 10:27 25 May 09

Hmm, strange that it is happening on both now - I don't consider myself an expert by any means, but it would appear to me to be a missing/loose/partially fitted connection. Perhaps one of the ZIF connectors, these are easily dislodged but not so easy to spot.

  barrybolton 10:38 25 May 09

I've just managed to get the packard bell one going after putting in a 60GB hard drive but the original 100GB out of it will not work on the acer (still blank screen) and on the packard bell it boots as far as me being able to press F2 OR F12 then on save and exit it goes to boot then i get the flashing - minus sign in top left hand corner

This thread is now locked and can not be replied to.

Huawei P10 review

1995-2015: How technology has changed the world in 20 years

An overview: What leading creative agencies are doing to improve diversity

New iPad, iPhone SE & Red iPhone 7 on sale now