Acer Laptop keeps restarting even before entering password to log in

  Sean Tan 12 Apr 12
Locked

Hi everyone,

I have an Acer laptop which has developed a problem:

Laptop spec: Acer Aspire 4930G Windows 7 Ultimate 4gb ram 250 hdd Bought in 2008 but it's treating me as good as a new laptop.

The problem: When I turn it on it goes through the start up process but when it get to the bit before I need to enter the password to log in, a blue screen with white text flashes on and then laptop restarts itself. The same process is going on and on without able to reach to the desktop screen.

I have tried and no success on the below: F8 on start up (Tried to repair and use last known good configuration) Put in Windoes 7 installer CD to repair (nothing comes up after I click repair, screen is on but waited ages and nothing happen).

I really dont want format my laptop as I have not back up all my files and documents and pictures (sadly I saved them in both C drive and D drive, which left me with no disk to format, else I would be happy to format it).

Some people suggest that it is the problem of graphic card, and some suggests it's cause by ram.

This problem is not just happen in windows 7, it happened on windows xp to some user back in 2008, which you can see from the below link. So I think this problem is not OS-specific.

I appreciate your suggestion and I am urgently need help because my exam is coming soon and I need to use my laptop T.T.

  northumbria61 12 Apr 12

Try this - Press and hold the Power button after startup for approx. 30-60secs then leave the laptop OFF for about 5 mins or longer then startup again.

  Sean Tan 12 Apr 12

Thanks Northumbria but I does not help =(

  Fruit Bat /\0/\ 12 Apr 12

Tap F8 at start up select safemode from the menu.

if it lets you in then back up your data before trying anything else.

  Sean Tan 12 Apr 12

As I said, I tried safemode too, but still cant get to desktop screen..

  buteman 12 Apr 12

Can you get it to do a system restore using CMD in safe mode.

At the command prompt, type rstrui.exe, and then press ENTER. Administrator permission required If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

  Sean Tan 12 Apr 12

Well the problem is there is no way (even in safemode) to access to the desktop. T.T

  Nontek 12 Apr 12

If you have any peripherals connected, like anything USB etc, try disconnecting them all and then try starting again.

  Nontek 12 Apr 12

PS - including external Hard-drive(s).

  buteman 12 Apr 12

If it lets you in there you could also do sfc /scannow or chkdsk.

If using CD or DVD have you changed the Bios for it to run DVD's first.Could also check the date and time as well to make sure that is Ok.

Much the same as northumbria61.

Remove the Battery and the power cord.Then hold the start button down for at least 30 seconds as that should get rid of any static.Connect the power cord and try without the battery connected.

  Fruit Bat /\0/\ 12 Apr 12

Boot from the DVD to command prompt and run chkdsk

Advertisement

This thread is now locked and can not be replied to.

Should I upgrade to Windows 10? 8 reasons why you should upgrade to Windows 10... and 2 why you…

We are being sold the ability to spend money we don't have. And we love it

Microsoft claims its new VR lens system is better than Oculus Rift's

Apple Music preview: Why Spotify should be scared of Apple's impressive new music-streaming service

We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message