Acer Aspire L/top 5920, Vista & Disabled Lan Prob

  Fried~Chips 21:01 04 May 08
Locked

I am using the laptop on wireless for now but I have found in device manager the Lan is showing error code 22 disabled. I keep enabling this but when rebooting laptop I re-check the Lan & it has reverted back to code 22 disabled again

This was the case before upgrading Bios, and before installing SP1 for vista.

Does anyone know if it is a bug with the Acer Lan which is "Broadcom Netlink Gigabit Ethernet Controller" ?

I have re-downloaded and installed the Acer driver for this device and also turned off power managment with no effect.

HELP Please as I may need to return laptop to Amazon if its faulty my days are running out

I did post earlier on Vista forum but no replies

  ambra4 21:30 04 May 08

Code 22

This device is disabled. (Code 22)

The device is disabled because a user disabled it by using Device Manager.

Click Enable Device. This starts the Enable Device wizard

  Fried~Chips 21:39 04 May 08

I keep going back into the deivce manager selecting the Broadcom device by clicking on properties and Enable Device which it does but then if I restart laptop or come back start it up next day its back to been disabled.

Can you explain where the Enable Device Wizard is please? or should this be visible when right clicking on the Broadcom Ethernet adpater in device manager

many thanks for your call

  Fried~Chips 22:15 04 May 08

Sorted it, Acer laptop comes with Acer empowering control gadget tool which has options within for controling net, sound, etc the Net control panel for some reason was disabled

Simply re-enabled connection, re-booted and it stayed enabled ! I

  Fried~Chips 22:16 04 May 08

I also suspect that it goes to being disabled when no Lan cable is connected.

  ambra4 22:47 04 May 08

Once the display icon is in the task bar and you disconnect the cable it should show with a red X if the icon is not showing

In the “Local Area Connection Properties” window

At bottom of display tick the box “Show Icon in Notification Area When Connected

His will show the icon at all time

You can also disable and enable by the following method if icon is not displayed

Start- Setting-Network Connection-Right click on Local Area Connection and disable or Enable as required

You also check the following

Right click on Local Area Connection Display Icon on task bar

Click Status-General-Properties

If IPv6 is ticked - untick as you don’t need to use at present and only slow down the

access to your ISP

At the top of display the type of Lan card will be displayed

Click Configure-Click-Advanced Tab

Click-Power Management Tab

Untick if selected "Allow Computer to turn this device off to save power

Network Connection Setting

Click-Start- Setting-Network Connection-New Connection Wizard

Select-Connect to the Internet-Next

Select-Set Up My Connection Manually-Next

Select-Connect using a broadband connection that is always on

Next-Finish

This thread is now locked and can not be replied to.

Sony Xperia XZ Premium review: Hands-on with the new 4K HDR phone with Motion Eye camera and Snapdr5…

1995-2015: How technology has changed the world in 20 years

Best laptop for design and art 2017: we test Apple, Dell, HP, Lenovo and Microsoft's best models…

CarPlay tips & troubleshooting guide: CarPlay tips & troubleshooting guide: Get the most from…