acer 1521 laptop

  grayhair 17:40 04 Feb 06
Locked

please help, my son decided to up grade his memmory
to 2g the daft sod did not check for compatability put in ddr400 533 the laptop only takes 333, powered up and nothing happend,put old memmory back in and yes nothing happend,power light is on nothing else no fan sound no hard drive sound nothing at all just power light.
is this now dead or is there something we can do,
please help

  onthebog 18:05 04 Feb 06

Double check that the original memory is correctly seated in its retainers.
If a RAM stick is even slightly off it will cause the symptoms you are experiencing. Some are more fiddly than others but a loose module will prevent the system from starting.

  grayhair 18:25 04 Feb 06

thanks onthebog just tried that and even swoped the moduels around and tried that and pressed to make sure but still no joy

  onthebog 19:59 04 Feb 06

If you can get into the system BIOS, try enabling 'failsafe' or 'default' settings. I'm guessing that mabey the memory timings have been altered.

Also, does your laptop use dual chanell DDR memory, because if it does then the modules will need to be installed as matched pairs.
click here

  grayhair 20:18 04 Feb 06

Unfortunatley the laptop does not display an image or anything responsive apart the power light,

is there a way to reset the cmos on this laptop?

i am not sure if it uses dual channel, but we have put the originals back in anyhow.


thanks.

  grayhair 21:03 11 Feb 06

thanks but we have sent it back to acer for them to sort out

This thread is now locked and can not be replied to.

Qualcomm Snapdragon 835 benchmarks: Antutu, Geekbench 4, GFXBench and PCMark results

1995-2015: How technology has changed the world in 20 years

This stop-frame animation tells a moving story of domestic violence for Refuge

New iPad 2017 preview: Apple's affordable but underspecced new iPad may appeal to the education…