Access - Removing a Relationship

  J0 17:15 08 Mar 04
Locked

I have created a database with relationships. Having now updated information I did not need one of the tables originally created so deleted it. My problem is that there was a relationship between my primary table and the one deleted and I am now getting a message saying

'The table or query name 'products' you entered in either the property sheet or macro is misspelled or refers to a tabel query that doesn't exist'

I haven't created a query or used the macro ?!?

Can anybody advise me on what to do next to get rid of the relationship that I can't see

Many thanks

  ///A M G 18:17 08 Mar 04

have you set a primary key?

  AccessMoron 18:47 08 Mar 04

When do you get the error?

  J0 08:36 09 Mar 04

I have set a primary key
The error appears when I click on the + sign in my main database file
I don't understand why that is still there when all the relationships have been deleted

  Chris the Ancient 11:33 09 Mar 04

Daft question... Have you tried repairing and compacting the database?

It may be that you deleted the table before you deleted the relationship and Access thinks the relationship is still there! This is bad news.

Have a look at the relationships window and see if the link is still there and connected to a phantom table or is just floating free (but highly unlikely) and delete it.

You may need (if possible) to reinstall the earlier version of the database and then make sure you delete the relationship before you delete the table.

Sorry I'm sounding gloomy, but...

Will look in again later

Chris

  Chris the Ancient 11:35 09 Mar 04

There is a darned good Access forum at click here where there are even more Access gurus than you can shake a stick at!

Chris

  J0 11:52 09 Mar 04

OK I have managed to get rid of the first error message by creating a new table with the same title but now I am being asked for a parameter value - whats one of them?

  Chris the Ancient 15:10 09 Mar 04

The parameter value is saying that it does not recognise the name of the field in the 'new' table. If you haven't called it by EXACTLY the same name, that can be a cause, but - and I've found this the hard way a couple of times - if the field name is exactly the same name, recreating the table has not been a viable answer :-((

Chris

  J0 15:15 09 Mar 04

Thanks Chris I went to link you provided and put my problem on there - see what happens
Thanks for the advice though

  J0 16:04 09 Mar 04

Chris - thought I would let you know I have solved the issue.
After much searching I went into Design View went into properties and change the subdatasheet to NONE and hey presto its ok and I have managed to create the new relationship which works.

Thanks for you help and advice from earlier

  Chris the Ancient 19:31 09 Mar 04

Glad you cracked it!

Chris

This thread is now locked and can not be replied to.

Surface Pro (2017) vs Surface Pro 4

20 groundbreaking 3D animation technologies coming to Siggraph 2017

iPad Pro 12.9 vs Surface Pro 5