320mb external hdd

hello, i have just bought the above, i have made a full system backup with norton ghost to it which seems fine, i tried to defrag it afterwards and it got to 3% and stayed there! so i tried diskeeper that got to 25% and stayed there!
am i doing something wrong? its my first externaml hdd
maxtor 3200
7200
usb2
thanks again
adam

also have just noticed, there seems to be a hell of a lot of activity from it. ie the lights flashing pretty much all the time

  silverous 16:10 13 Feb 07

Did you format it first?

yes i formated it, i cant see any jumpers, as its had my whole system o/s etc does windows know its a slave drive?

  Fruit Bat /\0/\ 17:56 13 Feb 07

All external drives via USB are Master. It will be slow to defrag that size drive via USB.

  Technotiger 18:05 13 Feb 07

Hi, why on earth did you want to defrag it. If it is a new drive and all you have done is put the back-up on it, it does not need to be defragged.

Defragging is for drives that have had some use and have items removed and re-installed and removed and lots of different programs installed, deleted items etc ... this is what causes drives to become fragmented, thus requiring defragmenting in order to tidy up the data again. This then enables items to load quicker and the system to run smoother. A new drive should not need defragging.

  Input Overload 18:14 13 Feb 07

If you have images on the drive it will take forever to defrag & there is no point.

  woodchip 18:22 13 Feb 07

You need to chop the disc up into partitions. it's a windows limit with defrage on a big drive

  GANDALF <|:-)> 18:32 13 Feb 07

YOU DO NOT NEED TOP DEFRAG AN EXTERNAL HD.......I have tghe feeling that some people do not listen.

G

so i guess i dont defrag it then?
i have been on there website and its not too helpful to say the least, it basically tells you where the cables go, i bought it because i have 2 internal hdds and most of the second was ghost backup files, and im thinking of putting vista on one of the drives so bought external just for back up, the only thing i did other than format it was change performance from (remove drive) to (performance) in devise manager.
so i guess everythings ok.
many thanks for the replies
adam

i thought i better defrag as all the files were red, its a complete backup of about 90 gb

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

The updated 'Corel Painter inside Photoshop' plugin ParticleShop offers new brushes

New MacBook Pro 2017 release date, UK price and tech specs: Kaby Lake MacBook Pro to launch in…