3 dongle installs every time I boot up

  migray52 10:03 AM 19 Mar 12

Hi, I have a 3 dongle for my internet connection. When I plug it into my laptop it just loads the program and just works. But using it on the desktop it detects new hardware every time, and I have to go through all the installation routine. Is there a simple fix? Many thanks Mike.

  northumbria61 10:46 AM 19 Mar 12

If any device driver is not automatically installed by Windows, the 'Found New Hardware' wizard will appear and ask you to point to suitable drivers on your hard drives, or offer to search for them on the Internet. It appears you may need to update the driver via Device Manager.

  migray52 11:35 AM 19 Mar 12

Hi northumbria, thanks for your input. I tried updating the driver but it came back "could not find a better driver" I wrote to let you know but when I clicked "post" the dongle had disconnected itself and it would not reconnect. On rebooting the PC it didn't go through the installation process or detect new hardware it just worked!!!! How bizarre is that. Mike.

  northumbria61 11:40 AM 19 Mar 12

Good to hear that - don't forget to use the "Safely Remove Hardware" option before removing each time.

How bizarre is that ? Could have been down to your USB port.

  migray52 12:02 PM 20 Mar 12

Same problem back again next time I booted up. Any more thoughts? Thanks.

  migray52 12:47 PM 20 Mar 12

FIXED...Control panel/System/Hardware/Driver signing. Select ignore, install without my permission..... Thanks.

  Aitchbee 13:08 PM 20 Mar 12

migray52 - I've had the same prob with my virgin 'dongle'...but your query and end result are a 'godsend'. Ta Much.


This thread is now locked and can not be replied to.

How to watch Rugby World Cup 2015 online: Watch live, catch up on-demand & stream the 2015 Rugby…

1995-2015: How technology has changed the world in 20 years

See immersive artist and storyteller Chris Milk speak at London VR event

What everyone thinks of the new Steve Jobs movie | 21 Facts about the Steve Jobs film | PLUS:…