2nd hard drive not showing

  BrianW 11:43 22 Feb 03
Locked

System - win98se on QDI Kinetiz 7b board. Duron 750 CPU. 512 mb 133 sdram. Master HDD 40gb WD, slave 20gb WD, CD-RW + DVD on secondary IDE. System was working fine until yesterday. I reformatted the master HD whilst trying to get my Duron 1300 working(see previous post). It didn't work, so I returned to the Duron750, reformatted again (Format c: /s). I then transferred the backed up system from slave drive using Drive Image 2002.(had to use the boot from A: drive route for some reason - kept getting "programme carried out illegal operation" when using the normal Disc Copy route). Everything seemed to be OK until I came to use the system today. "My computer" only shows one hard drive. BIOS sees 2, System Devices sees 2 but there is no drive number against the second and no option to assign a hard drive. I can boot from either by changing the BIOS boot order. When I look in Drive Image 2002 Disk 1 shows as Main Drive (C) 20 gb and Disk 2 shows as Main Drive(\\.\disk2part1 also 20gb). I've obviously done something to cause this but cannot see what. Any help would be appreciated. I'm stumped.

  tran1 11:57 22 Feb 03

I have exactly the same problem. I used partition magic to create another partition in FAT for Bootmagic and now it doesn't show my second hard drive. In 'My computer' it shows my main partition (XP) and Bootmagic partition.

Drive Image 2002 still sees the second hard drive but like what BrianW said; in this format:\\.\disk2part1. Partition magic show the second hardd rive as hidden but it cannot unhide it.

Can anyone offer advice to BrianW an me?

Is there a manual way to show the second hard drive?

  jazzypop 13:21 22 Feb 03

You could try a different partition manager, to see whether that can correct the error on the partition information table that Drive Image seems to have introduced.

There is a 30-day trial version of a decent utility at click here

Or try Ranish from click here (Ranish is more powerful, but slightly less 'user-friendly').

  BrianW 14:01 22 Feb 03

Well, I've found out what I did wrong, tran1, as Partition Magic is also made by Power Quest, you may have the same problem. I used the Rescue Diskette route to copy my drive across. In the book (which I didn't read) it explains that the version of DOS they use on the first of their two diskettes is Caldera DOS. This, not very helpfully uses the format "\\diskm.partn" If you wish to see and use the correct drive letters you need to use your Win 98 startup disk. You don't find this until you get to page 21 - no use for someone like me! Anyway, thats what the problem was. Apparently I can still make back-ups to the second hard drive in this format and it will boot from it OK. Something to sort on a rainy day. tran1 - I hope this helps. jazzypop, thanks as always for the input. Brian ;>{}

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Hands-on with the Star Wars fighting drones you can fly yourself

15 macOS Sierra tips | How to use macOS Sierra: Secret tricks and best new features in Apple's new…