2000 O/S choice

Iam running win2000( on C:) and xp on my system. I recently had a problem with a trojan horse virus and had to reload 2000. Since then I receive a message when trying to start up xp at o/s choices menu file corrupt or missing insert start up floppy and press r to repair this file.
I have tried this but system just wants to reload 2000 from new.
File is : windows\system32\config\systemd.
Can't find this file at all on start up disc. Is there any way to add this file from somewhere else or config a new file??? Don't really want to have to reload xp. Cheers.

Frustrated. lb

  temp003 04:41 09 Mar 03

The file is one of the XP registry files. 2 things have happened to your computer. One is the virus, the other is the W2k reinstallation.

Unless the virus has affected the XP system as well, it is quite possible that your XP registry file is actually not corrupt or missing, but it just cannot be loaded.

The problem may well be the w2k reinstallation, when w2k Setup overwrote the boot files. Both w2k and XP use the 3 boot files ntldr, ntdetect.com and boot.ini. When you set up the dual boot, XP Setup put the XP versions of the first 2 files on to C, which have no difficulty in recognising and loading an older OS like w2k. The w2k version of ntldr and ntdetect.com may not be able to load XP, being a newer OS.

Try replacing these 2 files now on your C drive with the XP version first, before attempting a solution with the XP registry.

Boot into w2k. Go to C, and see if you can see the 3 files. These are usually hidden, so if you can't see them, click Tools, Folder Options, view tab, and (1) tick "Show all hidden files and folders", (2) Untick "Hide file extensions for known file types" and (3) Untick "Hide protected operating system files". By doing (3), you also remove the Read-Only attribute of these files, so that you can replace them.

Put XP CD in. Select Perform other tasks, then Browse CD. Go to i386 folder and locate NTLDR and NTDETECT.COM

Copy them to the C drive. Say yes to replacing the existing files. When that's done, remove the XP CD.

Next check the boot.ini file. This file contains the paths to the operating systems on your computer, and determines what the OS selection screen (when you start computer) looks like.

Since you still get the XP option on that screen, the boot.ini file may well be fine.

Under C, double click the boot.ini file. It should open with Notepad. The only line you need to check is the one under [operating systems] which has "Microsoft Windows XP Home (or Professional)" /fastdetect.

The path should be multi(0)disk(0)rdisk(0)partition(n)\WINDOWS="Microsoft Windows XP Home (or Pro)" /fastdetect

where n= the partition number where XP is installed. So if XP is installed on the 2nd partition on the same hard disk, it should be partition(2), and so on. (I assume XP is on the same hard disk as Windows 2000.)

If that's OK, just exit Notepad.

Alternatively, go to the XP partition and find the file WINDOWS\system32\msconfig.exe

Double click it, msconfig will open. Select the boot.ini tab. Click "Check all boot paths". If it returns a message saying it appears all boot.ini lines for MS OS's are OK, then your boot.ini file should be fine.

Then restart the computer and select XP to see if it works. If it still returns the error message about the registry file, post back. There are MS articles which deal with it.

Temp 003 You are a genius!! Up and running again in both o/s. One more invaluable piece of info I would like to drag from you is. When the o/s menu appears it defaults to xp. I tried changing the the o/s commands round in boot.ini but it makes no difference. Is this defaulting because it is the newer o/s ?or is there a command I can change to allow 2000 to boot automatically??.

Once again a big fanx for your help.

Very happy, lb

  temp003 23:28 09 Mar 03

In either OS, right click My Computer, Properties, Advanced tab. Startup and Recovery.
In the box for default operating system, click the drop down list to select "Microsoft Windows 2000 Professional" /fastdetect.

You can change the timeout value to a shorter time (Display list of operating systems for how many seconds). But no shorter than 5 seconds if you want to have enough time to make a choice.

If you want the computer to boot automatically to Windows 2000, make it the default OS and change the time to zero seconds. Then you won't get the dual boot option screen and will go straight into your default OS.

The disadvantage of this is just in case Windows 2000 fails, you won't be able to boot into XP (because you need to get into one OS to change the timeout value). So if you're going to use this option, I suggest you make a bare boot floppy which can boot you into either OS.

In XP, put a floppy in. Right click drive A and select Format. Do not tick Quick format or other options. Just click Start. You must take this step for the floppy to work.

Then just copy the ntldr, ntdetect.com and boot.ini (which has a timeout value of at least 5 seconds) files from C to the floppy.

This floppy can bypass the hard disk and lets you boot into either Windows. Useful only as a backup of the boot files, and also for the event where your boot files have somehow got corrupt but the OS is otherwise fine. Has no other functions.

Test the floppy by restarting computer with it (making sure that in BIOS floppy drive comes before hard disk in boot sequence). If you still get a choice of OS's, and can boot into either OS, then the floppy works. (For you the OS to test is XP).

Then you can change the timeout value to 0, knowing that if Windows 2000 fails, you can still use the boot floppy to boot into Windows XP.

Fanx for all your help.

Cheers rich.

This thread is now locked and can not be replied to.

Apple Event as it happened | Apple October Event live blog: Apple unveils new MacBook Pro at…

1995-2015: How technology has changed the world in 20 years

Graeme Messer's exhibition aims to challenge fears and insecurities

New MacBook Pro release date, price and specs | New MacBook Pro 2016 announced: Now with Touch Bar…