2 OS's

  wingfield 09:43 30 May 04
Locked

I upgraded to XP from 2000. The first run it didn't complete. The second one did. I now find that when booting up I have a choice of 2 Microsoft XP Pro to choose from. How do I get rid of one of them or configure it so that it automatically boots from the right one?

  temp003 09:59 30 May 04

Are they both just called Microsoft Windows XP Professional (that is, no "Setup" in the title)?

If so, restart computer. When you see the menu (of the 2 OS's), make a mental note of which one has been highlighted (top or bottom), and which one works (top or bottom).

Post back.

  wingfield 13:07 30 May 04

They both have the same name. I know which one works and which one doesn't

  alan227 14:02 30 May 04

Click start/ click run/ type msconfig/ click ok/ click boot ini see if their are 2 entries if their are use notepad to delete one of them.

  temp003 15:55 30 May 04

Sorry, I didn't express myself very well. I meant to say, make a mental note when you see the OS menu and post back here and tell me which one is highlighted, and which one works (the top or the bottom one).

Anyway, do this.

Click Start, Run, type c:\boot.ini and press Enter.

Copy and paste the contents of the file here.

Then tell me which of the two XP choices works - the top one or the bottom one.

  wingfield 21:34 30 May 04

Ive been having problems logging into this site on the affected computer. I'm now logging on using another one. I'll see what I can do and get back. I should be able to e-mail it to myself and then copy and paste it into here via the e-mail.

  wingfield 21:46 30 May 04

temp003
Here it is

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINNT
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINNT="Microsoft Windows XP Professional" /fastdetect

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect

The one that works is the second one - if that is the order they appear in when I first boot up. I move the down arrow to select it

I think I also have a problem with my IE as this one seems to work OK (XP Home Edition) The other one is XP Pro

  wingfield 21:46 30 May 04

temp003
Here it is

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINNT
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINNT="Microsoft Windows XP Professional" /fastdetect

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect

The one that works is the second one - if that is the order they appear in when I first boot up. I move the down arrow to select it

I think I also have a problem with my IE as this one seems to work OK (XP Home Edition) The other one is XP Pro

  temp003 01:25 31 May 04

The one that doesn't work is installed in the WINNT folder (the old windows directory for w2k) - which must have been the upgrade attempt. The one that works is in the WINDOWS folder - which presumably was a clean fresh copy.

If you just want to edit out from the boot menu the copy that doesn't work, here's what you do.

Click Start, Run, type c:\boot.ini, click File,
Save AS, and save the file as A:\boot.ini to a floppy. This is to back up the file before you edit it.

Exit Notepad.

Click Start, Run, type c:\boot.ini again to open it.

Make 2 changes.

In the line that starts with "default=...", change the word WINNT to WINDOWS

In the section under [operating systems], delete the 1st line (that is, the line that refers to WINNT).

Having made these changes, click File, Save.

Exit Notepad. Restart. You should boot directly into the XP that works.

The above only changes the boot menu. The copy of XP that doesn't work is still on the computer.

When you're sure that XP Pro is working properly, you might want to delete the C:\WINNT folder.

A better alternative is to reformat the disk and clean install a fresh copy of XP Pro, after you have backed up all the data you need first.

  keith-236785 09:54 31 May 04

a simple way to sort this is to use a windows98 start up disk (get one from click here) start up with the disk in the floppy drive, at the menu choose option2, start without cdrom support.

once loaded to the prompt A:> type

fdisk /mbr & press enter

that should remove the boot loader options and revert back to loading straight into windowsxp proper.

  wingfield 16:28 31 May 04

Temp003

Cheers for that it's worked!!

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Alex Chinneck’s giant ice cube Christmas tree at Kings Cross

Apple rumours & predictions 2017: The iPhone 8, new iPads, and everything else you should expect fr7…