0x800B0001

  Tranestation 11:52 15 Apr 09
Locked

I have tried to use Windows Update and find I am getting the error message 0x800B0001. I am using XP / SP2 and have tried to follow MS instructions but dont seem able to get passed the run instructions here

Resolutions
1. Register the following files
Click Start.
Choose Run.
In the Run box, type regsvr32 wuapi.dll.
Click OK.
Repeat steps 1 through 4 for the following files: wuaueng.dll, wucltui.dll, wups.dll, wuweb.dll,atl.dll.

(my system tells me atl.dll is not a valid command)

I have also tried this

Register the following files
Click Start.
Choose Run.
In the Run box, type regsvr32 Softpub.dll.
Click OK.
Repeat steps 1 through 4 for the following files: Wintrust.dll, Initpki.dll, Mssip32.dll.


but with no luck as I just get boxes telling me to choose from a list to open the progs.

I can't fathom the KB 822798 article so can anyone advise me what is the correct procedure or is there another solution.

Any advice appreciated.

Mary Q

  rawprawn 11:58 15 Apr 09

Try disabling your AV before you update.

  OTT_Buzzard 11:58 15 Apr 09

First thing to do is to go to the Run box and type

services.msc

That will bring up a window with all the 'services' that your pc has to offer. Go to 'cryptographic services'

My bet is that it is listed as disabled or stopped.

if so:
Double click on it

Set 'Startup Type' as Automatic

Click 'Start'

Click OK

Hopefully all should be ok now. If not feel free to post back.....

  birdface 12:00 15 Apr 09

if nothing else works maybe try this.

click here

  MAJ 12:02 15 Apr 09

"(my system tells me atl.dll is not a valid command)"

If you got that error message then you didn't type:

regsvr32 atl.dll

you must have just typed

atl.dll

into the Run box. You have to precede each .dll listed, with the command

regsvr32

as shown above. Do each in turn, one at a time. If done correctly, you will get a message to say that the file has been registered successfully.

  Tranestation 12:07 15 Apr 09

Raw & Buzz

Thanks for your replies

I have tried the crypto services and it is running normally on auto and is started.

Any other thoughts /

Regards
Mary Q

  OTT_Buzzard 12:12 15 Apr 09

Just looking at KB822798:

check your computer date and time.....

Also, as Maj said, make sure each time you enter name of a dll to register, that it is preceeded by 'regsvr32'

  Tranestation 12:25 15 Apr 09

MAJ

Thanks for that............it really isn't that clear that each dll has to be prefixed. All were ok except regsvr32 Initpki.dll which seemed to do nothing...all the others seemed to succeed.

Regards Mary Q

  Tranestation 12:31 15 Apr 09

Buzz

Computer date and time ok

Regards
Mary Q

  Tranestation 12:35 15 Apr 09

MAJ

Open a command box and tried regsvr32 Initpki.dll and it succeded...........however no still no updates.

Regards
Mary Q

  OTT_Buzzard 12:35 15 Apr 09

i take it that the update still won't install then? initpki.dll should be needed for it to work.

try:

Open my computer, go to C:\Windows\System32 and see if you can find the initpki.dll file.

Rename the file to initpki_old.dll

click here to download a new version of the file. Copy it to C:\Windows\system32

Try and re-register it as before.

There are also a couple more things worth tryign from the MS KB article if that doesn't work

This thread is now locked and can not be replied to.

Best phone camera 2016/2017: Galaxy S7 vs iPhone 7 vs Google Pixel vs HTC 10 Evo vs OnePlus 3T vs…

1995-2015: How technology has changed the world in 20 years

Best Christmas Agency Projects of 2016

Super Mario Run preview | Hands-on first impressions of Super Mario Run: Mario's iPhone & iPad…