Icons aren't appearing in-game

  Manashoo 12:29 14 Jan 14
Locked

screenshot

so this thing, as you can see, happens. the game is called warlords battlecry 3. basically, all troops icons and the menu frame (in-game) dont appear, even though i can select my "invisible" troops. i try to install it on windows 8.0. it normally plays on windows xp, where it played normally. but no matter ho many times i tried to install it on my current pc this happened. i tried to erase any kind of data related but still. there's no way that my pc is too weak. could it be that the game is too old?

  mrwoowoo 02:51 17 Jan 14

You need to run it in compatability mode for Windows xp. 1. Right-click the program's icon and choose Properties.

2. When the Properties dialog box appears, click the Compatibility tab, and click inside the "run this programme in compatability mode for" box. Then in the drop down menu click on Windows xp (service pack 3). Then at the bottom click apply, and then click ok. If this doesn't work. Post back, and I will post a link for a software fix.

  batool100 06:01 21 Jan 14

If the icons are not appearing the game then You need to install it new.

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

The updated 'Corel Painter inside Photoshop' plugin ParticleShop offers new brushes

New MacBook Pro 2017 release date, UK price and tech specs: Kaby Lake MacBook Pro to launch in…