Framerate issues with GTA IV

  Si_L 16:01 PM 05 Dec 08

I've just started playing it, and its only hitting 4 to 5 FPS, its really jolty.

Minimum specs are:
Windows Vista SP1
AMD X2 64 2.4 Ghz
16GB Free HHD Space
256MB Nvidia 7900

My Specs:
Windows Vista SP1
AMD X2 5200+ 2.8Ghz
50GB Free HHD Space
512MB Nvidia 8600 GT

  citadel 17:22 PM 05 Dec 08

in the pc gamer review they said there were some major frame rate wobbles. you may need a better card for new games.

  STREETWORK 22:25 PM 05 Dec 08

i got the GT 8600 card and it plays fine. update the cards drivers...

  Si_L 02:25 AM 06 Dec 08

I'm going to stick with my card, it plays games like Bioshock and COD4 perfectly without any noticeable frame rate issues, so I will try updating the drivers.

  Si_L 15:45 PM 06 Dec 08

I went on the nVidia site and updated the card drivers, but it hasn't solved the problem. I think I will just take the game back as my specs suggest the game should run ok.

  adman 2 22:35 PM 07 Dec 08

click here theres a patch on the way, it runs ok for me unless i change any settings then it locks up straight away, i use xg drivers. theres an emergency patch coming up and steam are giving unconditional refunds which frankly means it sucks atm!

  adman 2 22:36 PM 07 Dec 08
  Si_L 01:29 AM 08 Dec 08

I'm gonna hold onto the game for now, even though it is bugging the hell out of me just cos I can't play it.

Another frustrating thing is, only an Xbox controller will work on it (USB adapted of course), which renders my PS2 pad and USB gaming pad useless. Plus, the game won't play unless you are logged into Windows Live and Rockstar Social Club, both required for online, but I don't want to do this every time I just want a bit of single player.

  adman 2 08:12 AM 08 Dec 08

click here hope this link works as i accessed it from my account, i played for a few hours last night, i got slow down at various times, the settings on the game are shocking at the mo, if i turn my settings down they go back up again? there's nothing really i can improve on this system. so i guess it just needs a little work, they say the settings go so high for future systems and yet it doesnt support sli yet?
hope they sort it quickly as i gave up waiting for conan to deliver what it promised, dx 10 multicore direct etc etc. as systems get more complex more problems are created i suppose, a wider range of beta testers may not be a bad idea before they put a game on the market.
good luck.

  Lexx R 08:38 AM 08 Dec 08

I cant seem to get decent STABLE frame rates!!!
normally runs at 18~30 fps on my system, no matter what I turn down or up, and i believe that I have a pretty decent system, 9800GT 512, X2 6000+ @ 3.1GHZ 2GB 1066 DDR2, the game sets render quality and detail to medium and high respectively, and res @ 1280x1024 the average frame rate I get is around 20fps tho if i can increase the res to 1600x1200, or decrease it to 1024x768 and lower everything to low...I still get roundabout the same average it would seem like its bad optimization on rockstars part.

For the xbox controller there is a fix, look here, click here
it works.


This thread is now locked and can not be replied to.

Best Android apps 2015/2016: Best apps for your new phone or tablet - what apps should I download?

1995-2015: How technology has changed the world in 20 years

Uniqlo uses your brain waves to find your perfect T-shirt

What everyone thinks of the new Steve Jobs movie | 21 Facts about the Steve Jobs film | PLUS:…