firmware problem with creative zen microphoto

  veronm1978 13:09 14 Jul 07

I'm not sure if in the right section or not but i was wondering would someone be able to help me out please i would be most grateful. i have a 4gb creative zen microphoto and when i tried downloading some music to it now i got a " firmware problem" error. I have tried getting it in to recovery by taking out the battery and turning it on while putting in the battery as this is supposed to kick start the recovery but it wont work and i cannot download anything from the creative site as it tells me my player is not pluged in. is there anyone who has had a problem like this before or does anyone know how to fix it please? i would be most grateful if someone would answer if you have the knowledge :-) Thanking you in advance veroncia

  ArrGee 02:08 22 Jul 07

It seems that your best bet will be to contact Creative directly, and also to have a good look through this site:

click here

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

This abstract video touches on division in our technologic world

Best alternatives to iTunes for Mac | Best music players for macOS: Free your music from the…