usb ports not working on new pc

  howard64 18:59 11 Aug 13
Locked
Answered

I have just built a new pc with an i5 4670k cpu on an Asus Z87. I loaded w7 home 64bit and all appears well. When I plug into any of the usb ports 2.0 or 3.0 the device is not recognized. In the bios the usb ports are enabled and windows device manager says they are all working correctly. Does anyone know what needs to be done to get them working?

  nickf 13:56 12 Aug 13
Answer

Try running SlimDrivers ( free program ) Never had any problems with it . If still no good , I would recommend Asus website , they may have an update there .

  Nontek 20:07 12 Aug 13

Start>Control Panel>Device Manager, then expand USB Controllers, then uninstall ALL USB Devices. Close Device Manager and re-start Computer.

Items should then be recognised, as on restart Windows will re-install all USB Ports.

  howard64 21:12 12 Aug 13

thanks nickf although windows device manager said all were working ok when I checked I found an unknown device which turned out to be the usb devices. I then installed again the usb drivers and now all is well. Thanks all for helping.

Advertisement

This thread is now locked and can not be replied to.

Driverless cars in the UK - The story so far: How Google and the UK Government are looking to test…

1995-2015: How technology has changed the world in 20 years

You can now publish data visualisations to the web from Power BI

Complete guide to Apple's campus 2, everything we know about the new spaceship HQ, plus: new drone…