Savastore Repair - Under Warranty

  Confab 12:47 24 Nov 05
Locked

There have been quite a few posts about Savastore (Watford Electronics) recently so I hope you don’t mind if I post this thread here. Nothing “bad” has happened yet but with the FE’s permission I’d like to post this.

On 13 September I took delivery of a new PC from Savastore. Nothing special, it’s from the Perfecta 5200 series, P4 3 ghz, 512MB RAM, 160GB HD, Radeon 9250 256MB graphics, XP Home SP2, Sony CDRW drive, 7 in one card reader and 1 years on site warranty. I have since added a DVDRW drive and a second 40GB HD for backups.

Everything worked almost perfectly, apart from the left channel sound coming out of the right headphone and visa versa (I can live with that). About two weeks ago I started to notice that the PC would randomly re-boot for no apparent reason. I’ve checked various things but the problem still persists and it’s got so bad that last night it must have rebooted a dozen times. I’ve decided to send it back for repair. This morning I logged on to the Savastore website filled out the necessary on line forms and posted the following description of the problem:-


“Within the last two weeks my PC keeps randomly rebooting. It doesn’t seem to matter if the PC is idle, just showing the desktop, or if I’m running processor intensive applications.
I’ve reinstalled the OS twice to reset back to factory settings but it still randomly reboots. The PC can sometimes run for a whole day and nothing happens then randomly reboot five of six times in an hour. It rebooted twice when I was trying to re-install Windows (at the wrong time I might add) and once when I was in the BIOS!
It doesn’t appear to be overheating, the processor shows about 50 degrees, I’ve run a RAM test which appeared OK. I’ve checked the error logs which don’t appear to show anything, I’ve run DR Watson which again didn’t show anything.
I get no error messages or BSOD and no freezing. The only way I can describe the problem is that it’s as if the re-set button on the front is being pressed at random intervals”


Savastore say on their site that they will respond within 48 hours so I’ll give them until Tuesday of next week to respond. The current status of the return is “Return not yet authorised”

I really hope that this doesn’t turn into a big saga and that my PC will be up and running shortly, but if history has a habit of repeating itself I could be in for a bumpy time.

I’ll keep you posted.

Confab

  Quiet Life 19:10 25 Nov 05

Have you tried this:
If you haven't changed any of the system failure settings, you should be able to see the error by looking in the Event Log. But a better long-term solution is to turn off the automatic reboot so you can actually see the error when it happens—chances are it will tell you enough about itself to let you troubleshoot further. To change the recovery settings to disable automatic rebooting:

1.
Right-click My Computer, and then click Properties.

2.
Click the Advanced tab.

3.
Under Startup and Recovery, click Settings to open the Startup and Recovery dialog box.

4.
Clear the Automatically restart check box, and click OK the necessary number of times.

5.
Restart your computer for the settings to take effect.


Now a fatal error occurs won't cause an automatic reboot and you can sort out what's causing the problem

  Confab 16:50 03 Dec 05

Thanks for the mail Quiet Life I did try what you suggested last Friday but I’ll update you with story so far.

I sent the return request to Savastore on 24th and received the promised response within 48 hours advising that a courier was coming to collect the computer on Wednesday 30th. Unfortunately they could not specify any particular time except between 9am and 6pm.

I took the afternoon of Friday 25th off from work with a view to trying to fix the issue once and for all. I reformatted the hard drive and reinstalled XP and only the basic drivers. I also connected my old laptop to the net and set it up next to my PC. I did as you said Quiet Life and stopped the PC from shutting down on an error. Within about 20 minutes the screen on my monitor went blue and I saw a STOP code. I searched for this on the net using my laptop, there wasn’t anything that matched the code perfectly but it seemed to point to the cheapo graphics card that I have. Great I thought and I was still searching the net for more information when something fell onto the workings of the laptop (the hinge is broken and there’s a small gap where part of the hinge should be). I just had enough time to see the thing glowing red on the circuit board before big blue plume of smoke appeared and the laptop went dead! It’s now in the garden.

Anyway, I removed the graphics card from the PC and again reformatted the hard drive and reinstalled XP and the drivers. The PC worked perfectly all day and all evening. Great, so I sent a mail off to Savastore saying I’d fixed it. Now this is no word of a lie but within 30 seconds of sending the mail my PC rebooted itself!! This time with no blue screen and no STOP error. It carried on rebooting about every five minutes after that with no STOP errors.

I was worried that the courier wouldn’t show because of my e-mail so I phoned Savastore the next day. I was on hold for about 45 minutes but did manage to get through to someone who said “no worries the courier will still show up”.

I thought it might be a temperature thing so I installed some software that shows the processor temps and fan speeds and sat in front of the PC waiting for it to reboot. Eventually it did but the processor temp was only at about 55 degrees and I know it runs perfectly at higher temperatures than that. It doesn’t seem to reboot when I take the side of the case off so I suspect it may be a temp thing but I can’t be sure. The PC only has a Processor fan and Power supply fan. The thing is, is that when I first got the PC it ran fine. I installed a 2nd HD for backups and a DVD RW and it worked fine. This has only started happening within the last few weeks. I’ve tried just about everything I can think of, I’ve taken out components and reseated them, re-installed, reformatted, even jiggled wires but I just can’t make it re-boot until it wants to.

Back to the courier – The night before he was due I took out the HD and DVD RW that I’d put in and put the graphics card back and I tried to set the PC back to how it was when I got it. It was then I realised that when I reformatted the hard drive using the XP disk that I’d deleted the restore partition, so I have just installed XP and all the drivers and left it at that. Luckily I still had the box and packaging the PC came it so packing wasn’t an issue. I took the next morning off work and the courier arrived at about 11 – That was lucky too as I just happened to glance out of the window to see him walking back to his van. It turned out that he’d been trying the doorbell and as he got no response thought that I wasn’t in. That’s when we discovered my doorbell had stopped working.

The PC is now with Savastore. It has been since Thursday. The status on the website just says repair being processed. I just hope it crashes when it’s there because if they can’t find a fault I get charged £35.00 plus VAT. I'm now using an old PII PC.

Just to make thing worse my wife said to me yesterday “I told you - you should have gone to Dell”

PLEASE SAVASTORE DON’T LET ME DOWN

Confab

  oresome 19:30 03 Dec 05

What happened to the "on site" warranty?

PS

Did the PC crash with the extra HD and DVD RW removed? If you've not tried this, it may never crash whilst being tested.

Not really fair on the repairers to alter the configuration before returning in my opinion unless you're 100% sure it crashes as was supplied.

  Confab 17:05 04 Dec 05

What happened to the "on site" warranty?

I think this means on "their site" as they arranged for a courier to come and collect the computer. I don't mind this as the fault is intermittent and I didn't really fancy the idea of someone possibly sitting in front of my PC for hours.

Did the PC crash with the extra HD and DVD RW removed?

I don't know because I didn't get a chance to test it. I know it didn't crash for months with them inside and then started to crash within the last two weeks. I was worried that if it went into repair with these inside then I might not see them again if the computer was replaced with a new one - not likely I know but possible.

If it doesn’t crash whilst being tested then (apart from paying them £35 plus VAT) I think I might change the PSU as the one inside is a 300w (I think) and I’m not sure if this is enough for a P4 3GHZ, CDRW, DVDRW and two HD’s. I’ll also add some case fans to cool things down a bit and then see how things go from there.

  g0slp 17:30 04 Dec 05

I was under the impression that this meant that the machine was repaired at the owner's location, not returned to the suppliers; this latter scheme was termed to be "RTB" (Return to base). Just a thought...

Confab, I hope that you get everything sorted out.

  Arnie 15:59 05 Dec 05

Confab.

You seem to be very computer literate. I am surprised that you did not choose to build your own system.

Also, did you not know about Savastore's customer support issues?

  Confab 17:16 07 Dec 05

Arnie, I toyed with the idea of building my own but it just seemed far easier selecting the components on their website that I wanted and having them build it for me. Less time consuming

I did do some research on the company and I admit I did have second thoughts about ordering from Savastore given their poor customer service reputation but I must have trodden on a crack in the pavement that day because I went ahead and ordered it anyway!

The website still says “repair being processed” – Its been a week today and I'm not sure how long I should give them before chasing.

  Arnie 18:59 07 Dec 05

I am sure everything will be sorted out in the end.
Unfortunately they do take their time.

Anyway, good luck.

Arnie.

  Confab 15:52 17 Jan 06

I e-mailed savastore this today. It's still re-booting!!

"I took delivery of the above pc in September 2005 and it was returned to you in November as it kept re-booting. I received the PC back with a new case fan fitted and the processor re "heat-pasted", unfortunately it still keeps randomly re-booting. I have tried system restore, I've re-formatted the Hard Drive and it doesn't make any difference. It doesn't appear to be overheating as the processor temp runs at about 55 degrees. It sometimes re-boots within 10 seconds of start up, sometimes when it's been running for hours. Last night it re-booted at least half a dozen times on the trot. I took the case side off and checked the hardware was seated properly and the connections secure and each time I tried to put the case side back on the PC re-booted. It seems to be some sort of intermittent hardware fault.

Another thing I mentioned the last time the PC was returned was that the left sound channel comes out of the right headphone and visa-versa. This was not fixed the last time the PC was returned.

I have tried to obtain an "RA" number from your website but each time I try I see the message "All invoiced quantities for item 10281925 has been returned" I don't know what this means and I can't get any further. I tried your customer services number but was advised by the person there that she could not give me an RA number, I would have to contact your department. I have tried phoning three times but each time the phone is disconnected after about 10 minutes.

Can you please help me."

I'm now pretty desperate!!!

  Forum Editor 23:05 17 Jan 06

with threads like this I have to issue a warning that any posts encouraging other people to boycott a supplier will automatically be deleted.

Let other people make their own minds as to which supplier they'll buy from.

This thread is now locked and can not be replied to.

Amazon Fire HD 8 review: A brilliant combination of function and value – with one massive caveat

1995-2015: How technology has changed the world in 20 years

How to create an introvert-friendly workplace

iPhone 7 review: Enhanced cameras, a refreshed design and water resistance make the iPhone 7 an…