Crucial UK website

  Ranger 16:48 25 Jan 03

anyone else out there having problems getting on to the crucial uk website, I have been trying for the last hour to get on with no luck

  TOPCAT® 16:55 25 Jan 03

Probably updating the site maybe. TC.

  Djohn 16:58 25 Jan 03

Tried just now and no probs. Give it another try.

  TOPCAT® 17:03 25 Jan 03

Must be some feeder line trouble. TC.

  Ranger 17:05 25 Jan 03

still can't get on, oh well I'll probably have to wait until tomorrow now

  Djohn 17:18 25 Jan 03

click here use the com. address and click on uk from there, top left under international.

  Ranger 17:20 25 Jan 03

Cheers DJohn, had already tried that, same result, can't get on

  'oppy 19:43 25 Jan 03

Ive just tried it too, getting this error message..

Sorry, Not Found. 404 File Not Found Error.


The URL path in your request was not found.

Please make sure that it is exactly as it should be. Also check the capitalization and that you are using forward slashes ( / ).

  Elrond 19:59 25 Jan 03

No joy here either. Must be updating

  TOPCAT® 22:07 25 Jan 03

Sorry. Site Temporarily Unavailable
Please check back later.

  anchor 17:24 26 Jan 03

Working OK today:

click here

This thread is now locked and can not be replied to.

Qualcomm Snapdragon 835 benchmarks: Antutu, Geekbench 4, GFXBench and PCMark results

1995-2015: How technology has changed the world in 20 years

This animated short film tells a moving story of domestic violence for Refuge

New iPad 2017 preview: Apple's affordable but underspecced new iPad may appeal to the education…